Hazard Flashers don't work - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 2nd Gen. Dodge Cummins 98.5-02 24V Forums > 98.5-02 Non-Powertrain
98.5-02 Non-Powertrain Discussion of 98-02 Topics Not related to the Powertrain...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 05-08-2011, 07:59 PM   #1 (permalink)
Newbie
 
Join Date: Dec 2010
Location: Rockwood, Mi.
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Hazard Flashers don't work

2000 Ram 2500 Hazard flashers don't work. Turn signals and brake lights work unless I turn on the hazard flashers then no turn signals,brak lights or hazard lights what is wrong ? I only see one flasher relay in fuse panel is there one for the hazards? If so were?
Thanks
Boscodn73 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-08-2011, 11:30 PM   #2 (permalink)
Cummins Enthusiast
 
dieselpower270's Avatar
 
Join Date: Mar 2011
Location: Washington
Posts: 297
Thanks: 19
Thanked 12 Times in 10 Posts
iTrader Score: 5 reviews
there is a flasher relay under the hood and there is a fuse in the cab. check those which it sounds like they still are good. it also might be the signal switch. try these but could be something else.
dieselpower270 is offline   Quick reply to this message
Old 05-08-2011, 11:57 PM   #3 (permalink)
Marble Crusher
 
MarbleCrusher's Avatar
 
Join Date: Mar 2009
Location: North North Texas
Posts: 1,860
Thanks: 44
Thanked 288 Times in 256 Posts
iTrader Score: 1 reviews
flasher relay and hazard relay are the same thing

-Jordan-
__________________
-02 Dodge 2500 cummins 4x4 6spd. Quadzilla XZT+, Volant CAI, road armor w/ lonestar guard front bumper line-x'd, Fass 95 , 3in lvl kit, bilstein shocks.
-68 F-100, grandad bought it new gave it to me when i was 16 been restoring bak to factory ever since.
MarbleCrusher is offline   Quick reply to this message
Old 05-10-2011, 10:25 AM   #4 (permalink)
Newbie
 
Join Date: Apr 2011
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
I have the same problem on my 1999 No Hazard but the turn and brake lights work.
morganwoody is offline   Quick reply to this message
Old 05-11-2011, 10:17 AM   #5 (permalink)
Newbie
 
BrwnDzel's Avatar
 
Join Date: Feb 2010
Location: Bradentucky, Fl
Posts: 43
Thanks: 2
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
I am chasing this issue on a '99. If I find out anything I will post...please do the same cause as of right now
__________________
97 2wd/removed silencer ring/KDP done!/4" turbo back mufflerless/Autometer Boost & Trans Temp/Mag hytec dd Trans pan/Aluminum rear axle cover
BrwnDzel is offline   Quick reply to this message
Old 05-11-2011, 11:43 AM   #6 (permalink)
Newbie
 
Join Date: Apr 2011
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Will do. I spent 20 bucks on a flasher and that did not help. Fuses check out with a meter. May try and replace them just to make sure.
morganwoody is offline   Quick reply to this message
Old 05-11-2011, 09:32 PM   #7 (permalink)
Cummins Fan
 
ShayetonKnake's Avatar
 
Join Date: Aug 2009
Location: Syracuse,Nebraska
Posts: 75
Thanks: 8
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
I had the same problem on my 99 there is two relays one under the hood and one in the cab next to the fuse panel i had a short and blew them out constantly so make sure u dont have a short
__________________
1999 Dodge ram 2500 Quad Cab 4X4 Auto[/B], Holset HE451VE Billet Wheel W/Fleece VGT controller, Lightning VP44,70HP Sticks,Edge JuiceWAttitude Level6UNL,Banghart Special Auto Trans with tripple disc converter billet input, Billet Flexplate,deep trans pan, Airdog 150GPH, K&N Intake,ATS T4 Exhaust Man,S&B Intake elbow, biggest cam without fly cutting pistons, Upgraded pushtubes and springs,Head ported all the way, 4inch Straight MBRP Duals, ARP 625 Head studs,fire ringed,12 valve rods, girdle kit,14mm main stud kit 17inch 3rd Gen rims with Mikey Thompson ATZ 315/70R17 [SIGPIC][/SIGPIC]
ShayetonKnake is offline   Quick reply to this message
Old 01-25-2012, 12:34 PM   #8 (permalink)
Newbie
 
Join Date: Mar 2010
Location: Shreveport, LA
Posts: 35
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Where was your short? I'm having this very probllem with mine.....
__________________
'99 2500 reg cab 4wd 5sp, smarty, F1 mach IV injectors, valair dual organic disc clutch, 53 block about to be converted to 55...more to come.
03 3500 qc 4wd auto, still in planning.
bmclemore82 is offline   Quick reply to this message
Old 02-17-2012, 06:23 AM   #9 (permalink)
Newbie
 
Join Date: Nov 2010
Location: New Orleans
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Flashers won't work

I have a 99 and a few days ago my emg. flashers just quit working---when turned on I have a fast blinking right turn signal in the cab, however nothing on the outside of the truck. I have replaced the interior 5 prong flasher unit, someone said there is one under the hood? I looked and didn't find a flasher unit?? I have all other lights-----just no emg. flasher----any idea's?????
Thanks
ONLYNAMRICA is offline   Quick reply to this message
Old 02-17-2012, 08:14 AM   #10 (permalink)
Cummins Fanatic
 
Join Date: Jan 2010
Posts: 161
Thanks: 79
Thanked 29 Times in 27 Posts
iTrader Score: 0 reviews
may also be a bad ground
__________________
2001 2500 auto isspro fuel pressure, isspro turbo boost, isspro trans temp, MBRP 4" turbo back.
jordan2468 is offline   Quick reply to this message
Old 05-05-2012, 11:01 AM   #11 (permalink)
Newbie
 
Join Date: Sep 2010
Location: Ne
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
im having the exact same problem on my 99 dodge. is there anyway to completely rewire the hazards? run them on a toggle switch? thanks
__________________
99 dodge 2500 4x4 reg cab 53 block (no prob yet) 156,000, no programmer, 4 in stainless exhaust, holey dash lol, and no hazards
zbkfarm is offline   Quick reply to this message
Old 05-05-2012, 11:44 AM   #12 (permalink)
Newbie
 
Join Date: Sep 2010
Location: Ne
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
also when i push down on the flasher switch i can hear the click in the flasher relay. but its just a single click not continuous.
__________________
99 dodge 2500 4x4 reg cab 53 block (no prob yet) 156,000, no programmer, 4 in stainless exhaust, holey dash lol, and no hazards
zbkfarm is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 12:29 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2