CD Player and Dome Lights quit working. - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 2nd Gen. Dodge Cummins 98.5-02 24V Forums > 98.5-02 Non-Powertrain
98.5-02 Non-Powertrain Discussion of 98-02 Topics Not related to the Powertrain...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 03-18-2010, 11:48 PM   #1 (permalink)
Cummins Fan
 
99DodgeCummins's Avatar
 
Join Date: Feb 2010
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
CD Player and Dome Lights quit working.

I don't have power to my cd player and my dome lights inside my cab doesn't work anymore. I took out the light under the hood that is connected to the hood and that stuff quit working so i reconnected to see if that would fix the problem and it didn't fix it. What could it be?
__________________
99, 5 Speed, SouthBend Dual Disc, 1 3/8 Shaft, F.A.S.S. 150/150, 150 Scheid Injects, Edge Drag Box/Smarty Stacked, 4" down pipe, 5" exhaust, ARP Head Studs, Ladder Bars, Safety Loops Front and Rear, weight rack, 2" leveling Kit, FP, Boost, Pyro Gauges
99DodgeCummins is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-19-2010, 12:52 AM   #2 (permalink)
Diesel Head
 
carson b's Avatar
 
Join Date: Dec 2009
Location: langley B.C. Canada
Posts: 1,103
Thanks: 28
Thanked 81 Times in 76 Posts
iTrader Score: 0 reviews
check for blown fuses use a test light dont just look at them
__________________
2001 dodge 3/4 ton 6 speed 4x4
4 inch bd exhaust with engine brake
edge juice computer and bd cold air intake
carson b is offline   Quick reply to this message
Old 03-19-2010, 02:01 AM   #3 (permalink)
Cummins Fan
 
cumminsnut69's Avatar
 
Join Date: Dec 2009
Location: Western South Dakota
Posts: 82
Thanks: 3
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
there is a power wire that supplies power to the cd player, dome lights, rear cab (just the cargo lamp) and power mirrors. if you changed the player without the battery dico'd then there is a chance you may have shorted that wire (this happens on my 00' 1/2 ton). it runs from the fuse block (under hood) through the back of the instrument cluster into a splitter for all above mentioned sources. its a massive pain but check those things also, if you lost those that may be your problem. i ended up running a wire from my in cab fuse block (using an extra port) to the distribution block then eveything worked again, good luck. use a multi-meter to check the wires
__________________
2007 5.9lcr 4x4. 48re w/ bd valve body, Raybestos bands, Alto clutches, BW gov sol, & billet struts sonnax servo/accumulator and suncoast triple tq. also muffler delete, an Edge w/attitude, Revtek leveling kit, and home made headache rack.
cumminsnut69 is offline   Quick reply to this message
Old 03-19-2010, 12:09 PM   #4 (permalink)
Cummins Fan
 
99DodgeCummins's Avatar
 
Join Date: Feb 2010
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
alright thanks that helps out alot.
__________________
99, 5 Speed, SouthBend Dual Disc, 1 3/8 Shaft, F.A.S.S. 150/150, 150 Scheid Injects, Edge Drag Box/Smarty Stacked, 4" down pipe, 5" exhaust, ARP Head Studs, Ladder Bars, Safety Loops Front and Rear, weight rack, 2" leveling Kit, FP, Boost, Pyro Gauges
99DodgeCummins is offline   Quick reply to this message
Old 03-19-2010, 12:25 PM   #5 (permalink)
Diesel Freak
 
countrymanlife's Avatar
 
Join Date: Feb 2007
Location: Spring, Texas
Posts: 606
Thanks: 78
Thanked 238 Times in 173 Posts
iTrader Score: 0 reviews
i lost these on my old 1500. check your fuses. Mainly in cab fuses the ones under the black covers (they can be overlooked when you are in there)
__________________
'02 2500 4x4 Quad Cab Auto - BHAF, Straight Pipe, 35x12.5r17 BFG KM2s, XD Hoss 17"s, 6" Franka-lift, DTT Tracbar, '98 HD steering, EMS Manual Hubs, PSC Gearbox, DSS Stabilizer, NFAB stepbars, and much more to come... Gotta Pay to Play
countrymanlife is online now   Quick reply to this message
Old 03-20-2010, 03:29 PM   #6 (permalink)
Cummins Enthusiast
 
mopar-or-no-car's Avatar
 
Join Date: Sep 2009
Location: Abbotsford, BC, Canada
Posts: 215
Thanks: 7
Thanked 27 Times in 18 Posts
iTrader Score: 0 reviews
Its the i.o.d. fuse
__________________
01.5 Ram 2500 4x4 5.9 DTT auto, quadcab, long box, ez/pm3, hx35, bd exhaust brake, bd towloc, sport lights, kool vue's, toyo's, fass, isspros, piaa'ss, daystar leveling kit, 4" magnaflow tbe SOLD
mopar-or-no-car is offline   Quick reply to this message
Old 03-20-2010, 04:27 PM   #7 (permalink)
Cummins Nut
 
mrclean's Avatar
 
Join Date: Dec 2006
Location: Altoona, Pa.
Posts: 424
Thanks: 0
Thanked 46 Times in 45 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by mopar-or-no-car View Post
Its the i.o.d. fuse
As Mopar said......IOD fuse. Should be #12 in the fuse panel on the side of the dash.
__________________
'99 3500, QC, 5-spd, FASS, PacBrake, van Aaken Smartbox
mrclean is offline   Quick reply to this message
Old 03-20-2010, 04:56 PM   #8 (permalink)
Diesel Freak
 
Mingle's Avatar
 
Join Date: Apr 2009
Location: Marion, NC
Posts: 670
Thanks: 10
Thanked 26 Times in 25 Posts
iTrader Score: 0 reviews
IOD fuse. 10Amp. It's the one with the big black cover around it, just pop it open and pull it out. Bet that's it :P
__________________
'99 2500 24V. Auto. AD100. Quadzilla Adrenaline, 4" turbo back (straight piped), BD-Power HPVP44, BD Stealth Plate, Boost Elbow. Built Trans.
Mingle is offline   Quick reply to this message
Old 03-20-2010, 06:54 PM   #9 (permalink)
Newbie
 
Dwalker.98Cummins's Avatar
 
Join Date: Feb 2010
Location: South of Abilene, Texas
Posts: 40
Thanks: 8
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Quote:
Originally Posted by cumminsnut69 View Post
there is a power wire that supplies power to the cd player, dome lights, rear cab (just the cargo lamp) and power mirrors. if you changed the player without the battery dico'd then there is a chance you may have shorted that wire (this happens on my 00' 1/2 ton). it runs from the fuse block (under hood) through the back of the instrument cluster into a splitter for all above mentioned sources. its a massive pain but check those things also, if you lost those that may be your problem. i ended up running a wire from my in cab fuse block (using an extra port) to the distribution block then eveything worked again, good luck. use a multi-meter to check the wires
My truck did the same thing an no my battery wasn't dissconected when i was trying to put an aftermarket cd player in it.... so what is the easiest way to correct the problem?
__________________
98.5 24v 2500 5 spd. 4x4 Ext. Cab. Laramie SLT long bed straight 4" exhaust. Superchip max micro tuner.. NON 53 BLOCK hah
Dwalker.98Cummins is offline   Quick reply to this message
Old 03-23-2010, 03:39 AM   #10 (permalink)
Cummins Fan
 
cumminsnut69's Avatar
 
Join Date: Dec 2009
Location: Western South Dakota
Posts: 82
Thanks: 3
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
you need to pull the dash apart the distribution block is mounted to the back of the housing where the instrument cluster mounts, but you cant get to it throught the cluster housing, unfortunetly you have to go in under the dash. you can either pull the power supply wire (once you find it; mine where all white) out of the bundle all the way to the block under the hood or just use an empty spot in you in dash fuse block and run a "hot" wire up to the distribution block. this is a massive pain it fustrated me for days after checking all the fuses and relays i found i had shorted the wire and burned the prong at the source.
__________________
2007 5.9lcr 4x4. 48re w/ bd valve body, Raybestos bands, Alto clutches, BW gov sol, & billet struts sonnax servo/accumulator and suncoast triple tq. also muffler delete, an Edge w/attitude, Revtek leveling kit, and home made headache rack.
cumminsnut69 is offline   Quick reply to this message
Old 03-23-2010, 01:03 PM   #11 (permalink)
Newbie
 
Join Date: Dec 2008
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I have a similar problem with my 99 2500, but it's only the cd player. I don't want to thread Jack you but I didn't want people saying that I should of posted in this thread either. My problem is that the radio and everything works normal BUT the cd player. I have the stock Premium speaker package (infinity I think) and the cd player stopped working one day in the stock head unit. I replaced the stock head unit with an after market head unit and it still doesn work. The wierd part is, is that both the stock and aftermarket head units function completely (especially cd player) in my friends 2500.
__________________
'99 2500 5speed 2001 engine swap, hx-40, AD150, Edge Comp, Jammer Stg 5 sticks, 4" turbo back stack, HID halo's, 2" leveling kit, 35's, AEM Intake, pillars, plenty of more done and more to come....
____Kurt____ is offline   Quick reply to this message
Old 03-24-2010, 02:03 AM   #12 (permalink)
Newbie
 
Dwalker.98Cummins's Avatar
 
Join Date: Feb 2010
Location: South of Abilene, Texas
Posts: 40
Thanks: 8
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
oh just to let yall no all i had to do was replace my I.O.D. fuse. it had blown. just put a new one in an was good to go....

Later
Doug
__________________
98.5 24v 2500 5 spd. 4x4 Ext. Cab. Laramie SLT long bed straight 4" exhaust. Superchip max micro tuner.. NON 53 BLOCK hah
Dwalker.98Cummins is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 11:09 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2