ABS & Brake Light stuck on - 1999 Ram 2500 4X4 CTD...? - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 2nd Gen. Dodge Cummins 98.5-02 24V Forums > 98.5-02 Non-Powertrain
98.5-02 Non-Powertrain Discussion of 98-02 Topics Not related to the Powertrain...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 09-25-2009, 08:22 PM   #1 (permalink)
Newbie
 
Join Date: Sep 2009
Location: Pittsburgh
Posts: 38
Thanks: 0
Thanked 4 Times in 3 Posts
iTrader Score: 0 reviews
ABS & Brake Light stuck on - 1999 Ram 2500 4X4 CTD...?

Any suggestions where to start poking around?

I just bought a 1999 Ram 2500 SLT. It is 4WD. 5.9 Cummins. Automatic.

The Brake and ABS light are stuck on. I haven't had much time to poke around with it and see whats going on. But was hoping this was maybe a common issue with these trucks and a simple fix.

Any suggestions?

Thanks guys,

Joe


PS - The power difference going from a 1992 F350 7.3 IDI to a 99' Cummins with Hypertech, Cold Air, and 5" Stack is UNREAL...
__________________
2006 Ram 3500 4X4 5.9L G56 QCLB DRW - Bone Stock other than Valair Twin Organic Quiet
CarnageZ28 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-25-2009, 08:38 PM   #2 (permalink)
Cummins Nut
 
UtahDodgeCummins's Avatar
 
Join Date: Sep 2009
Posts: 350
Thanks: 12
Thanked 29 Times in 20 Posts
iTrader Score: 0 reviews
Disconnect the negative battery cables and turn your lights on. Leave it for about 10 minutes and that should clear it up. I had the same problem on my truck once. They came on after I tried to put the truck in 4 Hi.
__________________
'00 2500 Auto QuadCab ShortBed 105k- Quadzilla Adrenaline, BD performance elbow, 4" straight pipe exhaust, AirDog 100 w/custom bracket, BD Fuel pressure sensor, Autometer boost and pyro, EV2 Fuel Pressure, 55 block , BD APPS Noise Isolator, BHAF
UtahDodgeCummins is offline   Quick reply to this message
Old 09-25-2009, 08:38 PM   #3 (permalink)
Cummins Fanatic
 
Join Date: Apr 2008
Location: Ridge, New York
Posts: 133
Thanks: 0
Thanked 22 Times in 22 Posts
iTrader Score: 0 reviews
I'd try the rear ABS sensor first. It's on the top of the rear differential. Just unplug it and remove the bolt holding it in, and then pull it out. Watch for the o-ring. There might be some metal shavings stuck to it as it's magnetic. You can try cleaning it off and reinstall it. That worked once for me, but I eventually had to replace the sensor. I had the same problem as you on my '98 12 valve 4X4. My truck has 4 wheel ABS.
prattman is offline   Quick reply to this message
Old 09-25-2009, 08:57 PM   #4 (permalink)
Newbie
 
Join Date: Sep 2009
Location: Pittsburgh
Posts: 38
Thanks: 0
Thanked 4 Times in 3 Posts
iTrader Score: 0 reviews
Thanks guys! Work all day tomorrow. Hope to have time Sunday to play around with it and get it straightened out.

Appreciate the fast responses. This is my first Dodge so wasn't sure what I was getting myself into here haha...
__________________
2006 Ram 3500 4X4 5.9L G56 QCLB DRW - Bone Stock other than Valair Twin Organic Quiet
CarnageZ28 is offline   Quick reply to this message
Old 09-25-2009, 08:58 PM   #5 (permalink)
Diesel Freak
 
v10sport's Avatar
 
Join Date: Feb 2009
Location: Elkhorn, WI
Posts: 801
Thanks: 12
Thanked 76 Times in 71 Posts
iTrader Score: 1 reviews
Your speedo working?
__________________
07 5.9L 2500 QC/LB 4x4. Edge J/A, Smarty TNT, AFE stage 2/ progaurd 7 filter Arson III 2G intake horn 6" lift 37 13.5 17 SS M-16 5"TBE Full Billet trans.
2012 3500 4x4 Auto DRW 4:10's Max tow. 5" TBE, EGR delete, CCV delete, Minii Maxx
v10sport is offline   Quick reply to this message
Old 09-26-2009, 05:46 PM   #6 (permalink)
Newbie
 
Join Date: Sep 2009
Location: Pittsburgh
Posts: 38
Thanks: 0
Thanked 4 Times in 3 Posts
iTrader Score: 0 reviews
Speedo works fine.
__________________
2006 Ram 3500 4X4 5.9L G56 QCLB DRW - Bone Stock other than Valair Twin Organic Quiet
CarnageZ28 is offline   Quick reply to this message
Old 09-26-2009, 11:43 PM   #7 (permalink)
Diesel Freak
 
Waldershrek's Avatar
 
Join Date: Sep 2008
Location: The Empire State
Posts: 535
Thanks: 7
Thanked 12 Times in 12 Posts
iTrader Score: 0 reviews
Sounds dumb but check your fuses also.
__________________
01 Dodge Ram 2500//262,000 miles and counting//AFE Stage 2 air box AFE dry flow filter and pre-filter//Raptor 150//Diamond Eye 4" stainless dual exhaust//Isspro Ev2 fuel pressure gauge
Waldershrek is offline   Quick reply to this message
Old 09-27-2009, 08:31 AM   #8 (permalink)
Cummins Nut
 
Super10brss's Avatar
 
Join Date: Jul 2009
Posts: 481
Thanks: 134
Thanked 37 Times in 21 Posts
iTrader Score: 1 reviews
Mine is stuck on too

Seems the guy I bought mine from swapped out the front hubs with non ABS units You can see ABS wires dangling down...

I heard some where you can replace the bearings in the "stock" hub with Timken bearings and rock on with out having to buy the whole unit.... Any body know what the deal is on that.?.?.?.
__________________
1998 cab-chasis Utility bed #100 fuel plate 3K GSP Garmon trans
Super10brss is offline   Quick reply to this message
Old 09-27-2009, 01:44 PM   #9 (permalink)
Cummins Nut
 
UpInSmoke02's Avatar
 
Join Date: Mar 2009
Location: Bellingham, WA
Posts: 347
Thanks: 3
Thanked 15 Times in 14 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by Super10brss View Post
Mine is stuck on too

Seems the guy I bought mine from swapped out the front hubs with non ABS units You can see ABS wires dangling down...

I heard some where you can replace the bearings in the "stock" hub with Timken bearings and rock on with out having to buy the whole unit.... Any body know what the deal is on that.?.?.?.
You'll spend more in shop time and parts than buying new ones. IMO
__________________
'02 2500 4X4 ADR W/ PULSE, S&B CAI, S&B Intake Elbow, FASS 150, BD SO VP44, Diamond Eye 4", 2.5" HBS Level Kit w/ Bilstein 5100's, 33" MTR's, DT Pro Fab Steering Box Stabilizer Next up: Tranny, Turbo, Sticks
UpInSmoke02 is offline   Quick reply to this message
Old 09-27-2009, 01:51 PM   #10 (permalink)
Cummins Nut
 
UpInSmoke02's Avatar
 
Join Date: Mar 2009
Location: Bellingham, WA
Posts: 347
Thanks: 3
Thanked 15 Times in 14 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by CarnageZ28 View Post
Any suggestions where to start poking around?

I just bought a 1999 Ram 2500 SLT. It is 4WD. 5.9 Cummins. Automatic.

The Brake and ABS light are stuck on. I haven't had much time to poke around with it and see whats going on. But was hoping this was maybe a common issue with these trucks and a simple fix.

Any suggestions?

Thanks guys,

Joe


PS - The power difference going from a 1992 F350 7.3 IDI to a 99' Cummins with Hypertech, Cold Air, and 5" Stack is UNREAL...
Check the hub bearing for play... grab the wheel top and bottom, try to move it back and forth. You're looking for no movement.

Sounds like one of the sensors is toast. The front sensors are located on the hub. You just have to take the wheel, caliper and rotor off to get to it. I believe a 6mm allen is what you need to take it out.

They're about $60 to replace or if you have to replace the hubs, they come with it.
The rear is on the diff.
__________________
'02 2500 4X4 ADR W/ PULSE, S&B CAI, S&B Intake Elbow, FASS 150, BD SO VP44, Diamond Eye 4", 2.5" HBS Level Kit w/ Bilstein 5100's, 33" MTR's, DT Pro Fab Steering Box Stabilizer Next up: Tranny, Turbo, Sticks
UpInSmoke02 is offline   Quick reply to this message
Old 09-28-2009, 05:27 PM   #11 (permalink)
Diesel Head
 
DieselRiot's Avatar
 
Join Date: Apr 2008
Location: New Jersey
Posts: 1,274
Thanks: 21
Thanked 91 Times in 80 Posts
iTrader Score: 5 reviews
The dealer has the scanner to read the codes for abs
__________________
2008. EFI Live By Cummins-Tuner. Copilot. 5" TBE. S&B Intake With Scoop. GDP Mega-Flo With Boost Tube. GDP Pro-Gate. GDP CCV Delete. WCC Silencer Ring Mod. Rail Shim. Fass Ti 150. ARP 425's.
DieselRiot is offline   Quick reply to this message
Old 09-28-2009, 09:07 PM   #12 (permalink)
Newbie
 
bigjim17's Avatar
 
Join Date: Jun 2009
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by v10sport View Post
Your speedo working?

my abs and brake light are both on and my speedo dont work? any ideas
__________________
1998.5 24v, edge juice w/attitude, 100hp injectors, cold air intake, 5 in stack,
bigjim17 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 04:43 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2