wont go into overdrive - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 2nd Gen. Dodge Cummins 94-98 12V Forums > 94-98 Powertrain
94-98 Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 07-23-2013, 06:16 PM   #1 (permalink)
Cummins Enthusiast
 
khunter_2007's Avatar
 
Join Date: Aug 2008
Location: whiteman afb
Posts: 236
Thanks: 5
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
wont go into overdrive

i have a 94 47rh that will not go into overdrive at all. I have the pot for the tps and swapped that out with a new one and I also have the 1000 h resistor in the tranny temp port also swapped that out today as well. everything worked fine this way for years but now it is not. I am throwing some codes tho they are
24 Throttle position sensor voltage too high or too low
37 Open or short in the Torque converter clutch solenoid CKT circuit or
Voltage high or low at transmission Temperature sensor
and it is throwing the code twice what does that mean
my question is were to go from now
also I just test drove the truck and parked it now my fuel shutoff solenoid will not engage unless I manually lift if do I have a short in my wireing somewhere or whats going on
any help would be great
__________________
94 cummins , hx40 , 5.014, 4k gov springs, 60lb springs, laser cut dvs , cam , lockup controler , tci stage 5 tc , suncoast valve body , 150 shot , #10 plate slid , afc slid, billet input, steel planetarys, extreme duty clutch kit , 6 in . stacks
khunter_2007 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-23-2013, 07:38 PM   #2 (permalink)
Cummins Enthusiast
 
khunter_2007's Avatar
 
Join Date: Aug 2008
Location: whiteman afb
Posts: 236
Thanks: 5
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I found a bad wire terminal on the battery and fixed that and a cut in my tranny temp wire fixed that and now my shut off solenoid is working took for a test drive and wouldn't go into overdrive the first 2 tries but did the next three and locked up thetc all seamed fine then it quit going into od again. came back and looked at the codes and now I only have 37 once 24 is gone
any ideas
__________________
94 cummins , hx40 , 5.014, 4k gov springs, 60lb springs, laser cut dvs , cam , lockup controler , tci stage 5 tc , suncoast valve body , 150 shot , #10 plate slid , afc slid, billet input, steel planetarys, extreme duty clutch kit , 6 in . stacks
khunter_2007 is offline   Quick reply to this message
Old 07-23-2013, 08:36 PM   #3 (permalink)
Cummins Enthusiast
 
khunter_2007's Avatar
 
Join Date: Aug 2008
Location: whiteman afb
Posts: 236
Thanks: 5
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
found two more gouged wire on the connector on the tranny fixed that and test drove would go in the first 2 times but did every time after but am still throwin 37 once
guess ill do some more diging throughthe wires and test drive more Tom
__________________
94 cummins , hx40 , 5.014, 4k gov springs, 60lb springs, laser cut dvs , cam , lockup controler , tci stage 5 tc , suncoast valve body , 150 shot , #10 plate slid , afc slid, billet input, steel planetarys, extreme duty clutch kit , 6 in . stacks
khunter_2007 is offline   Quick reply to this message
Old 07-26-2013, 06:48 PM   #4 (permalink)
Cummins Fan
 
Join Date: Aug 2011
Location: So. Cal
Posts: 80
Thanks: 5
Thanked 4 Times in 4 Posts
iTrader Score: 1 reviews
Keep digging man!! Im in the same boat. I originally went through and cleaned all ground contact points and batt terminals and it worked great for about a week. I just replaced the lockup solenoid and it worked for 1/2 a day and now I'm stuck again.
I'll let you know if I find something.
__________________
2001 2500 5.9 4x4 180,000mi. Banks Stinger kit]
Dr. Wood is offline   Quick reply to this message
Old 07-26-2013, 11:21 PM   #5 (permalink)
Newbie
 
josh97's Avatar
 
Join Date: Apr 2013
Location: ottumwa ia
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
My 95 woulnt shift into overdrive an i found switch under the dash that looks like a brake light switch was bad...Sounds stupid but drive it and lift up on the brake pedal with ur foot and see if it works...I think its a 15 dollar part...I will try to get u a part number and pic...

http://www.oreillyauto.com/site/c/de...e+light+switch
__________________
95 2500 4x4 auto no plate 4k springs 180 p pump, 191 dv's 90 horse injectors, Borg warner T6 turbo...Over the 500hp mark!!!!

Last edited by josh97; 07-26-2013 at 11:27 PM.
josh97 is offline   Quick reply to this message
Old 07-26-2013, 11:55 PM   #6 (permalink)
Diesel Head
 
country_hick's Avatar
 
Join Date: May 2011
Location: Maine
Posts: 7,350
Thanks: 6
Thanked 1,427 Times in 1,155 Posts
iTrader Score: 0 reviews
That is a brake light switch. It has an extra set of contacts that are not needed for the brakes. It could easily be the issue.
__________________
1997 3500 club cab 3.54 gears towing & camper pkg. Still stock with a built transmission at 120k. 4" exhaust, 4kgsk, and exhaust brake waiting for installation. Still need ideas for improvements for hauling 15k fifth wheel.
country_hick is offline   Quick reply to this message
Old 07-27-2013, 09:04 AM   #7 (permalink)
Cummins Fan
 
Join Date: Mar 2010
Location: Finland
Posts: 92
Thanks: 5
Thanked 10 Times in 10 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by country_hick View Post
That is a brake light switch. It has an extra set of contacts that are not needed for the brakes. It could easily be the issue.
It's more precisly a brake pedal switch, as there are three sets of contacts; one normally open for brake lights, and two normally closed for OD and cruise control. When you press the pedal, NO contacts close turning the brake lights on, and NC contacts open, cutting the ground from the OD and CC.
Not sure about the original switch as it was burn when I changed it, but the SMP switch I bought for replacement was an adjustable one. You could extend the plunger/piston, then press the pedal and mount the switch, then when you released the pedal it pushed the plunger/piston to correct depth.
__________________
'95 Dode Ram SLT 4x4, 47RH w/built converter (billet, carbon clutch, stall dropped),KDP fixed, BHAF, Z-Series Pyro/Boost/Trans temp

Last edited by HeikkiH; 07-27-2013 at 11:35 AM.
HeikkiH is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 02:16 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2