wont go into overdrive - Dodge Cummins Diesel Forum
94-98 Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-23-2013, 07:16 PM Thread Starter
Cummins Enthusiast
 
khunter_2007's Avatar
 
Join Date: Aug 2008
Location: whiteman afb
Posts: 239
Thanks: 5
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
wont go into overdrive

i have a 94 47rh that will not go into overdrive at all. I have the pot for the tps and swapped that out with a new one and I also have the 1000 h resistor in the tranny temp port also swapped that out today as well. everything worked fine this way for years but now it is not. I am throwing some codes tho they are
24 Throttle position sensor voltage too high or too low
37 Open or short in the Torque converter clutch solenoid CKT circuit or
Voltage high or low at transmission Temperature sensor
and it is throwing the code twice what does that mean
my question is were to go from now
also I just test drove the truck and parked it now my fuel shutoff solenoid will not engage unless I manually lift if do I have a short in my wireing somewhere or whats going on
any help would be great


94 cummins , hx40 , 5.014, 4k gov springs, 60lb springs, laser cut dvs , cam , lockup controler , tci stage 5 tc , suncoast valve body , 150 shot , #10 plate slid , afc slid, billet input, steel planetarys, extreme duty clutch kit , 6 in . stacks
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
khunter_2007 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-23-2013, 08:38 PM Thread Starter
Cummins Enthusiast
 
khunter_2007's Avatar
 
Join Date: Aug 2008
Location: whiteman afb
Posts: 239
Thanks: 5
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I found a bad wire terminal on the battery and fixed that and a cut in my tranny temp wire fixed that and now my shut off solenoid is working took for a test drive and wouldn't go into overdrive the first 2 tries but did the next three and locked up thetc all seamed fine then it quit going into od again. came back and looked at the codes and now I only have 37 once 24 is gone
any ideas

94 cummins , hx40 , 5.014, 4k gov springs, 60lb springs, laser cut dvs , cam , lockup controler , tci stage 5 tc , suncoast valve body , 150 shot , #10 plate slid , afc slid, billet input, steel planetarys, extreme duty clutch kit , 6 in . stacks
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
khunter_2007 is offline  
post #3 of 7 (permalink) Old 07-23-2013, 09:36 PM Thread Starter
Cummins Enthusiast
 
khunter_2007's Avatar
 
Join Date: Aug 2008
Location: whiteman afb
Posts: 239
Thanks: 5
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
found two more gouged wire on the connector on the tranny fixed that and test drove would go in the first 2 times but did every time after but am still throwin 37 once
guess ill do some more diging throughthe wires and test drive more Tom

94 cummins , hx40 , 5.014, 4k gov springs, 60lb springs, laser cut dvs , cam , lockup controler , tci stage 5 tc , suncoast valve body , 150 shot , #10 plate slid , afc slid, billet input, steel planetarys, extreme duty clutch kit , 6 in . stacks
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
khunter_2007 is offline  
post #4 of 7 (permalink) Old 07-26-2013, 07:48 PM
Cummins Fanatic
 
Join Date: Aug 2011
Location: So. Cal
Posts: 104
Thanks: 5
Thanked 6 Times in 6 Posts
iTrader Score: 1 reviews
Keep digging man!! Im in the same boat. I originally went through and cleaned all ground contact points and batt terminals and it worked great for about a week. I just replaced the lockup solenoid and it worked for 1/2 a day and now I'm stuck again.
I'll let you know if I find something.

2001 2500 5.9 4x4 209,600 mi. Banks Stinger kit.
BHAF, Fass 150, 100HP SAC Injectors.
Dr. Wood is offline  
post #5 of 7 (permalink) Old 07-27-2013, 12:21 AM
Newbie
 
josh97's Avatar
 
Join Date: Apr 2013
Location: ottumwa ia
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
My 95 woulnt shift into overdrive an i found switch under the dash that looks like a brake light switch was bad...Sounds stupid but drive it and lift up on the brake pedal with ur foot and see if it works...I think its a 15 dollar part...I will try to get u a part number and pic...

http://www.oreillyauto.com/site/c/de...e+light+switch

95 2500 4x4 auto no plate 4k springs 180 p pump, 191 dv's 90 horse injectors, Borg warner T6 turbo...Over the 500hp mark!!!!

Last edited by josh97; 07-27-2013 at 12:27 AM.
josh97 is offline  
post #6 of 7 (permalink) Old 07-27-2013, 12:55 AM
Diesel Head
 
country_hick's Avatar
 
Join Date: May 2011
Location: Maine
Posts: 10,955
Thanks: 6
Thanked 2,753 Times in 2,072 Posts
iTrader Score: 0 reviews
That is a brake light switch. It has an extra set of contacts that are not needed for the brakes. It could easily be the issue.

1997 3500 club cab 3.54 gears towing & camper pkg. Still stock with a built transmission at 120k. 4" exhaust, 4kgsk, and exhaust brake waiting for installation. 37337 upgrade. Still need ideas for improvements for hauling 15k fifth wheel.
country_hick is offline  
post #7 of 7 (permalink) Old 07-27-2013, 10:04 AM
Cummins Fan
 
Join Date: Mar 2010
Location: Finland
Posts: 98
Thanks: 5
Thanked 11 Times in 11 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by country_hick View Post
That is a brake light switch. It has an extra set of contacts that are not needed for the brakes. It could easily be the issue.
It's more precisly a brake pedal switch, as there are three sets of contacts; one normally open for brake lights, and two normally closed for OD and cruise control. When you press the pedal, NO contacts close turning the brake lights on, and NC contacts open, cutting the ground from the OD and CC.
Not sure about the original switch as it was burn when I changed it, but the SMP switch I bought for replacement was an adjustable one. You could extend the plunger/piston, then press the pedal and mount the switch, then when you released the pedal it pushed the plunger/piston to correct depth.

'95 Dode Ram SLT 4x4, 47RH w/built converter (billet, carbon clutch, stall dropped),KDP fixed, BHAF, Z-Series Pyro/Boost/Trans temp

Last edited by HeikkiH; 07-27-2013 at 12:35 PM.
HeikkiH is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome