97 12 valve * AUTOMATIC TRANNY NOT SHIFTING * HELP PLEASE! - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 2nd Gen. Dodge Cummins 94-98 12V Forums > 94-98 Powertrain
94-98 Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 12-03-2010, 06:08 PM   #1 (permalink)
Diesel Freak
 
nostroker's Avatar
 
Join Date: Mar 2009
Location: Decatur, Texas
Posts: 738
Thanks: 19
Thanked 26 Times in 25 Posts
iTrader Score: 0 reviews
97 12 valve * AUTOMATIC TRANNY NOT SHIFTING * HELP PLEASE!

I just bought a 1997 Dodge Ram 2500 extended cab truk with 256-k miles. Was unable to drive it and now I find out the transmission does not shift at all.

It acts like it is starting out in 2nd gear. Tried to shift it myself and even push the od buttonon and off with no luck. I did notice that the tack is not working and the abs and brake light are both on.

Any ideas?
__________________
Just a farm truck, with some extras!
2007.5 Dodge Ram 3500 C/C 6.7L, auto, 9'.4" CM HAULER BED, front replacement, H&S XRT with deletes and S&B INTAKE!
nostroker is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-03-2010, 06:18 PM   #2 (permalink)
Cummins Fanatic
 
Join Date: Jun 2008
Location: Greenup, KY
Posts: 157
Thanks: 22
Thanked 29 Times in 15 Posts
iTrader Score: 0 reviews
Maybe a solenoid in the transmission is bad. Your best luck will probably be to get it checked by a reputable transmission mechanic.
__________________
2002 Dodge Dakota SLT, Regular Cab, 4x4, V6 Magnum, Flowmaster dual exhaust
BigRig_88 is offline   Quick reply to this message
Old 12-03-2010, 07:35 PM   #3 (permalink)
Diesel Head
 
Join Date: Sep 2009
Location: Arapahoe, NC
Posts: 2,217
Thanks: 9
Thanked 298 Times in 266 Posts
iTrader Score: 0 reviews
Try to find someone with an OBD II scanner with live data and let them check it while running. This will allow you to see what the PCM sees in all it's inputs. Problems you are having could be just as simple as an ESS (engine speed sensor) bad or more complicated as bad wiring and many, many other things, but first step I think is to see what PCM sees to start diagnosing. You need to properly diagnose before buying any parts.
__________________
'96 Dodge 3500,KDP killed, boost-pyro-trans temp, not stock anymore
'01 Dodge 2500 4X4, EC, LB, 6 speed, FP-pyro-boost,
'97 Chevrolet Suburban, K1500, 4.10 gears
RPegram is offline   Quick reply to this message
Old 12-06-2010, 11:45 AM   #4 (permalink)
Diesel Freak
 
nostroker's Avatar
 
Join Date: Mar 2009
Location: Decatur, Texas
Posts: 738
Thanks: 19
Thanked 26 Times in 25 Posts
iTrader Score: 0 reviews
Well we put a Snap-On scanner on it today and it show governor pressure sensor and rear abs sensor. We cleared the codes and was able to shift it manually then when we stoped the codes came back on.

I found a new pressure sensor for $48.00 and abs senor for $46.00. Guess we will try this and see what happens now.
__________________
Just a farm truck, with some extras!
2007.5 Dodge Ram 3500 C/C 6.7L, auto, 9'.4" CM HAULER BED, front replacement, H&S XRT with deletes and S&B INTAKE!
nostroker is offline   Quick reply to this message
Old 12-07-2010, 11:56 PM   #5 (permalink)
Newbie
 
espn1044's Avatar
 
Join Date: Jan 2008
Location: Alamosa, Colorado
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
just be sure to replace the pressure sensor and gov pressure solinoid at the same time, i didnt do this the first time mine was acting up and i had to do it twice, i think u can get them as a get for $110
__________________
just a lil 6 cylinder haha
espn1044 is offline   Quick reply to this message
Old 12-08-2010, 12:02 PM   #6 (permalink)
Diesel Freak
 
nostroker's Avatar
 
Join Date: Mar 2009
Location: Decatur, Texas
Posts: 738
Thanks: 19
Thanked 26 Times in 25 Posts
iTrader Score: 0 reviews
Thanks, Just did that yesterday. My mech called and told me that I should replace both at the same time. Cost $48 for on and $41 for the other from a local tranny supply house down the street from me.

Hope to have it going today.
__________________
Just a farm truck, with some extras!
2007.5 Dodge Ram 3500 C/C 6.7L, auto, 9'.4" CM HAULER BED, front replacement, H&S XRT with deletes and S&B INTAKE!
nostroker is offline   Quick reply to this message
Old 12-13-2010, 12:41 AM   #7 (permalink)
Diesel Freak
 
nostroker's Avatar
 
Join Date: Mar 2009
Location: Decatur, Texas
Posts: 738
Thanks: 19
Thanked 26 Times in 25 Posts
iTrader Score: 0 reviews
No shift problem fixed!

Well after replacing both gov pressure parts in the tranny we ended up fixing the problem with a $120 engine speed sensor (cps). Someone had taken it completely off of the engine. But still can not figure ot why we was not getting any codes for that.

Any way the truck is fixed and shifts perfect now.
__________________
Just a farm truck, with some extras!
2007.5 Dodge Ram 3500 C/C 6.7L, auto, 9'.4" CM HAULER BED, front replacement, H&S XRT with deletes and S&B INTAKE!
nostroker is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 10:45 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2