97 12 valve * AUTOMATIC TRANNY NOT SHIFTING * HELP PLEASE! - Dodge Cummins Diesel Forum
94-98 Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 12-03-2010, 06:08 PM Thread Starter
Diesel Freak
 
nostroker's Avatar
 
Join Date: Mar 2009
Location: Decatur, Texas
Posts: 804
Thanks: 27
Thanked 29 Times in 28 Posts
iTrader Score: 0 reviews
97 12 valve * AUTOMATIC TRANNY NOT SHIFTING * HELP PLEASE!

I just bought a 1997 Dodge Ram 2500 extended cab truk with 256-k miles. Was unable to drive it and now I find out the transmission does not shift at all.

It acts like it is starting out in 2nd gear. Tried to shift it myself and even push the od buttonon and off with no luck. I did notice that the tack is not working and the abs and brake light are both on.

Any ideas?


Just a farm truck, with some extras!
2007.5 Dodge Ram 3500 C/C 6.7L, auto, 9'.4" CM HAULER BED, front replacement, H&S XRT with deletes and S&B INTAKE!
nostroker is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 12-03-2010, 06:18 PM
Cummins Fanatic
 
Join Date: Jun 2008
Location: Flatwoods, KY
Posts: 160
Thanks: 22
Thanked 36 Times in 15 Posts
iTrader Score: 0 reviews
Maybe a solenoid in the transmission is bad. Your best luck will probably be to get it checked by a reputable transmission mechanic.

1964 Dodge W200 Power Wagon, Crew Cab, Manual

2002 Dodge Dakota SLT, Regular Cab, 4x4, V6 Magnum, Auto, Flowmaster dual exhaust
BigRig_88 is offline  
post #3 of 7 (permalink) Old 12-03-2010, 07:35 PM
Diesel Head
 
Join Date: Sep 2009
Location: Eastern NC
Posts: 2,230
Thanks: 9
Thanked 300 Times in 267 Posts
iTrader Score: 0 reviews
Try to find someone with an OBD II scanner with live data and let them check it while running. This will allow you to see what the PCM sees in all it's inputs. Problems you are having could be just as simple as an ESS (engine speed sensor) bad or more complicated as bad wiring and many, many other things, but first step I think is to see what PCM sees to start diagnosing. You need to properly diagnose before buying any parts.

'96 Dodge 3500,KDP killed, boost-pyro-trans temp, not stock anymore
'01 Dodge 2500 4X4, EC, LB, 6 speed, FP-pyro-boost,
'97 Chevrolet Suburban, K1500, 4.10 gears
RPegram is offline  
post #4 of 7 (permalink) Old 12-06-2010, 11:45 AM Thread Starter
Diesel Freak
 
nostroker's Avatar
 
Join Date: Mar 2009
Location: Decatur, Texas
Posts: 804
Thanks: 27
Thanked 29 Times in 28 Posts
iTrader Score: 0 reviews
Well we put a Snap-On scanner on it today and it show governor pressure sensor and rear abs sensor. We cleared the codes and was able to shift it manually then when we stoped the codes came back on.

I found a new pressure sensor for $48.00 and abs senor for $46.00. Guess we will try this and see what happens now.

Just a farm truck, with some extras!
2007.5 Dodge Ram 3500 C/C 6.7L, auto, 9'.4" CM HAULER BED, front replacement, H&S XRT with deletes and S&B INTAKE!
nostroker is offline  
post #5 of 7 (permalink) Old 12-07-2010, 11:56 PM
Newbie
 
espn1044's Avatar
 
Join Date: Jan 2008
Location: Alamosa, Colorado
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
just be sure to replace the pressure sensor and gov pressure solinoid at the same time, i didnt do this the first time mine was acting up and i had to do it twice, i think u can get them as a get for $110

just a lil 6 cylinder haha
espn1044 is offline  
post #6 of 7 (permalink) Old 12-08-2010, 12:02 PM Thread Starter
Diesel Freak
 
nostroker's Avatar
 
Join Date: Mar 2009
Location: Decatur, Texas
Posts: 804
Thanks: 27
Thanked 29 Times in 28 Posts
iTrader Score: 0 reviews
Thanks, Just did that yesterday. My mech called and told me that I should replace both at the same time. Cost $48 for on and $41 for the other from a local tranny supply house down the street from me.

Hope to have it going today.

Just a farm truck, with some extras!
2007.5 Dodge Ram 3500 C/C 6.7L, auto, 9'.4" CM HAULER BED, front replacement, H&S XRT with deletes and S&B INTAKE!
nostroker is offline  
post #7 of 7 (permalink) Old 12-13-2010, 12:41 AM Thread Starter
Diesel Freak
 
nostroker's Avatar
 
Join Date: Mar 2009
Location: Decatur, Texas
Posts: 804
Thanks: 27
Thanked 29 Times in 28 Posts
iTrader Score: 0 reviews
No shift problem fixed!

Well after replacing both gov pressure parts in the tranny we ended up fixing the problem with a $120 engine speed sensor (cps). Someone had taken it completely off of the engine. But still can not figure ot why we was not getting any codes for that.

Any way the truck is fixed and shifts perfect now.

Just a farm truck, with some extras!
2007.5 Dodge Ram 3500 C/C 6.7L, auto, 9'.4" CM HAULER BED, front replacement, H&S XRT with deletes and S&B INTAKE!
nostroker is offline  
Sponsored Links
Advertisement
 
Closed Thread
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome