Coolant Temp Sensor - Dodge Cummins Diesel Forum
94-98 Non-Powertrain Discussion of 94-98 Topics Not related to the Powertrain...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-02-2010, 01:20 AM Thread Starter
Newbie
 
Firosche's Avatar
 
Join Date: Apr 2010
Location: Nampa, ID
Posts: 14
Thanks: 2
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Coolant Temp Sensor

Is it common for the coolant temp sensor to go out? Where is It located?

Firosche is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-03-2010, 01:07 AM Thread Starter
Newbie
 
Firosche's Avatar
 
Join Date: Apr 2010
Location: Nampa, ID
Posts: 14
Thanks: 2
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Sorry guys its a 1996 automatic. Looks like there is an air temp sensor but not a coolant sensor on the 96 12 valve.
Firosche is offline  
post #3 of 7 (permalink) Old 05-03-2010, 07:05 AM
Diesel Head
 
Join Date: Sep 2009
Location: Eastern NC
Posts: 2,230
Thanks: 9
Thanked 300 Times in 267 Posts
iTrader Score: 0 reviews
It's located near the top of head on driver's side at the back. A real pain to get to. Check to make sure it is plugged in correctly.

'96 Dodge 3500,KDP killed, boost-pyro-trans temp, not stock anymore
'01 Dodge 2500 4X4, EC, LB, 6 speed, FP-pyro-boost,
'97 Chevrolet Suburban, K1500, 4.10 gears
RPegram is offline  
post #4 of 7 (permalink) Old 05-03-2010, 11:37 AM
Diesel Head
 
Join Date: Nov 2005
Location: Montana
Posts: 16,224
Thanks: 27
Thanked 2,272 Times in 1,601 Posts
iTrader Score: 0 reviews
It's not common for the coolant temp sensor to fail but very common for them to get unplugged.
Upper right below.


Bill
'95 2500 4wd auto
'95 3500 5 speed heavy hauler
Stock for one day
illflem is offline  
post #5 of 7 (permalink) Old 05-03-2010, 12:34 PM Thread Starter
Newbie
 
Firosche's Avatar
 
Join Date: Apr 2010
Location: Nampa, ID
Posts: 14
Thanks: 2
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
I love the diagram! I will check it out and let you know. It is very clean under the hood so I would guess they pressure washed the motor so I spent some time there...
Firosche is offline  
post #6 of 7 (permalink) Old 05-03-2010, 02:32 PM
Diesel Head
 
ykdave's Avatar
 
Join Date: Feb 2008
Location: Yellowknife, NT, Canada
Posts: 10,782
Thanks: 20
Thanked 960 Times in 749 Posts
iTrader Score: 0 reviews
yea, its just a single wire plug, nothing fancy, should be 'easy' to find!

Just need to hire a little chinaman to do the job

2015 3500 laramie dually. 6.7, aisin, 4.10s, bone stock... (for now )
2014 forest river XLR 395amp, 42.5ft of truck killing, wind catching, toy and booze hauling, fun...
ykdave is offline  
post #7 of 7 (permalink) Old 05-03-2010, 03:57 PM Thread Starter
Newbie
 
Firosche's Avatar
 
Join Date: Apr 2010
Location: Nampa, ID
Posts: 14
Thanks: 2
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Alright so I found it, but there was no wire attached. Found the wire a little bit later. Gonna have to get another one cause its fubar.
Firosche is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome