P0121 Help Please - Dodge Cummins Diesel Forum

911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-16-2008, 04:54 PM Thread Starter
Diesel Head
 
kalkhokm's Avatar
 
Join Date: Oct 2006
Location: Eastern WV
Posts: 1,122
Thanks: 1
Thanked 9 Times in 7 Posts
iTrader Score: 0 reviews
P0121 Help Please

ive been noticing recently that when i am accelerating the throttle is "jumpy" or "spotty" and just today i kicked the CEL. checked it out and its a P0121 - throttle position sensors voltage does not agree with MAP (or something like that).

where is the throttle position sensor so i can check the connection and try cleaning it?? also, i thought the 99's had APPS, is it the same thing??


'06 Megacab 4x4
kalkhokm is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-17-2008, 06:38 AM
Newbie
 
Join Date: Jan 2008
Location: Short Hill Mt Morning Shade, VA
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by kalkhokm View Post
ive been noticing recently that when i am accelerating the throttle is "jumpy" or "spotty" and just today i kicked the CEL. checked it out and its a P0121 - throttle position sensors voltage does not agree with MAP (or something like that).

where is the throttle position sensor so i can check the connection and try cleaning it?? also, i thought the 99's had APPS, is it the same thing??
Its under the black plastic cover above the injection pump; driver side, front top of engine. I think you're right, it really means the APPS ... do you know how to reset it? Its easy.

Do you have an exhaust brake? It could be a dirty MAP sensor? see Mopar1973Man's Web Site for good info on how to clean that.

see this thread
Apps (throt Position Sensors) On National Backorder!!!! My Truck Is Down!

No mention of the MAP in my code chart.

00 2500 2nd Gen. 4wd. Headaches and deer catchers. Blue Ridge Diesel fuel gauge kit. Goose and receiver hitches. LB. Quad Cab.200k (not me).

Last edited by brickMan; 02-17-2008 at 06:42 AM.
brickMan is offline  
post #3 of 4 (permalink) Old 02-17-2008, 11:27 AM
Diesel Head
 
Mopar1973Man's Avatar
 
Join Date: Feb 2006
Location: New Meadows, Idaho
Posts: 24,623
Thanks: 2,143
Thanked 3,915 Times in 3,060 Posts
iTrader Score: 0 reviews
P0121 Accelerator Position Sensor (APPS) Signal Voltage Too Low APPS voltage input below the minimum acceptable voltage.

Basically the APPS sensor is off the end of the scale... Try a APPS reset first...

Michael Nelson -=- 2002 Dodge Ram Cummins 5.9L -=- 1996 Dodge Ram Magnum 5.9L
-= My articles have not been deleted. Just moved to a new location. Look for the "Articles" tab at the top of the web page! =-
Mopar1973Man is online now  
post #4 of 4 (permalink) Old 02-17-2008, 11:35 AM Thread Starter
Diesel Head
 
kalkhokm's Avatar
 
Join Date: Oct 2006
Location: Eastern WV
Posts: 1,122
Thanks: 1
Thanked 9 Times in 7 Posts
iTrader Score: 0 reviews
thanks guys ill try the resest...

'06 Megacab 4x4
kalkhokm is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome