No Dash LIGHTS! - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > General Forums > 911 Urgent Situations
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 10-13-2011, 03:23 AM   #1 (permalink)
Newbie
 
Join Date: May 2011
Posts: 44
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
No Dash LIGHTS!



Going Elk hunting in the mountains Friday, today I will be going up to help set up camp. Won't get back down the mts. till dark. I hooked up my truck to a trailer and a few minutes later, my lights went out. I then later found out it blew the 15amp Park LmP fuse. I replaced it. This evening about 6 days later after that incident, it blew the same fuse again.

I do not have any idea whats going on? I mean I was not hooked up to the trailer when this fuse blew again. Any ideas? My brake controller does not light up when I put my foot on the brake either.

I do not want to have to have my cab light on the whole time or keep replacing fuses to go to and fro. NEED HELP!
__________________
1999 Dodge Ram 2500 Laramie SLT 4x4 Automatic w/47RE(Triple disk TC, tow/haul VB). Quad cab, Short box. 24V 5.9L CTD w/53 block(No CRACK!). 3.55 Gears, 285/75/16's. AirDog II 165, 2-cycle oil at a 128:1 mix, BHAF. DAP 75HP Injectors. Over 200k miles.
hex0rz1 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-13-2011, 09:18 AM   #2 (permalink)
Diesel Head
 
GAmes's Avatar
 
Join Date: Sep 2009
Location: Killeen, TX
Posts: 6,618
Thanks: 36
Thanked 744 Times in 655 Posts
iTrader Score: 6 reviews
On a majority of vehicles the dash lights are on the same circuit as the tail/parking lights, so if the dash lights aren't working you probably don't have tail lights or front parking lights either. Try removing all four bulbs and inspect them closely for internal shorts. While you are at it look at the wiring for the sockets.
__________________
97 3500, 2 WD, G56, slightly bombed, A million+miles. Started the second million on 8/24/13
If you are lucky enough to be in Texas, you are lucky enough.
GAmes is offline   Quick reply to this message
Old 10-13-2011, 01:47 PM   #3 (permalink)
Newbie
 
Join Date: May 2011
Posts: 44
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
I replaced the drivers side tail light housing before I hooked up the trailer and put new bulbs in the back up light sockets. But, I will check the wiring and bulbs.

I was also considering replacing the 7-way plug as well while I'm at it, just to eliminate the possibility. The plug is smashed up anyways.

I will post back ASAP with my progress.
__________________
1999 Dodge Ram 2500 Laramie SLT 4x4 Automatic w/47RE(Triple disk TC, tow/haul VB). Quad cab, Short box. 24V 5.9L CTD w/53 block(No CRACK!). 3.55 Gears, 285/75/16's. AirDog II 165, 2-cycle oil at a 128:1 mix, BHAF. DAP 75HP Injectors. Over 200k miles.
hex0rz1 is offline   Quick reply to this message
Old 10-15-2011, 10:05 PM   #4 (permalink)
Cummins Enthusiast
 
Join Date: Jun 2011
Posts: 206
Thanks: 22
Thanked 11 Times in 9 Posts
iTrader Score: 0 reviews
my 02 did the same thing and it ended up being the dimer switch... apparently if you play with it to much it gets hot and will melt the plastic on the wiring... and then it shorts. lol so look up under your dash...
__________________
02 2500-edge comp-afe/K&N intake-4" exhaust to 6" stack. (Waiting for the VP to die )
12v Block, crank, and rods awaiting a new idea...
12v5.9 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 11:39 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2