no power, stalls, low idle - Dodge Cummins Diesel Forum
911 Urgent Situations Emergency Forum , Need Help Fast ? Post Here ! Urgent Topics Only...NO ADVERTISING

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-17-2009, 10:57 PM Thread Starter
Join Date: Jun 2009
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
no power, stalls, low idle

I just picked up a 1995 diesel 5.9 auto. The truck has a really low idle and feels like it doesnt have any power. Also when i put the truck into gear and give it has it will stall. The return hose was leaking off the back on the injector pump and i replaced it with a fuel injection hose. This didnt really change the way it ran and still has thoes problems. Could this have something to do with the fuel shutdown solonoid? thanks

talonkid119 is offline  
Sponsored Links
Sponsored Links
Closed Thread

Quick Reply

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome