Help !! oil pressure drops when idling - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 1st Gen. Dodge Cummins 89-93 12V Forums > 89-93 Powertrain
89-93 Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 10-18-2010, 06:42 PM   #1 (permalink)
Cummins Enthusiast
 
rebeldodge1993's Avatar
 
Join Date: May 2010
Location: alvin, tx
Posts: 284
Thanks: 5
Thanked 7 Times in 7 Posts
iTrader Score: 0 reviews
Help !! oil pressure drops when idling

alright I need advice my oil pressure drops off the gauge when my truck idles and when I shift but it builds back up when I get up in higher rpms ?? I changed the oil pressure switch out about a year ago and has lifetime warranty would this be bad connection in switch or would this be oil pump cause oil pump is mechanical and either it works or it shouldn't right ? any ideas
__________________
1993 d/w250 LE 5 speed & 4x4 conversion- s300, 4in custom exhaust, M&H timing spacer, BHAF, Denny T Pump top, Ptroke Coolertubz, 99 Pstroke intercooler, 366 spring, SDX 5x14's (140's) airdog 150gph, 3 piece manifold, pump tuned up and KDP tabbed
rebeldodge1993 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-18-2010, 09:23 PM   #2 (permalink)
Newbie
 
Join Date: Oct 2010
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Quote:
Originally Posted by rebeldodge1993 View Post
alright I need advice my oil pressure drops off the gauge when my truck idles and when I shift but it builds back up when I get up in higher rpms ?? I changed the oil pressure switch out about a year ago and has lifetime warranty would this be bad connection in switch or would this be oil pump cause oil pump is mechanical and either it works or it shouldn't right ? any ideas
If it were my truck I would plumb a mechanical gauge under the hood to see what its actually reading first, then if it was that low I would do an oil pump and hope that fixed it. Not a problem you really want to mess around with...

Edit: Yes oil pumps are mechanical, when they are worn they produce low oil pressure.

Last edited by Confused_Pete; 10-18-2010 at 09:26 PM.
Confused_Pete is offline   Quick reply to this message
Old 10-19-2010, 06:20 AM   #3 (permalink)
Cummins Nut
 
Join Date: Mar 2010
Location: Ann Arbor, MI
Posts: 498
Thanks: 0
Thanked 29 Times in 26 Posts
iTrader Score: 0 reviews
what he said!

Get a gage with numbers on it so you can see what it really is; the gage pin sitting on 'L' isn't going to tell you anything useful. On the oil pump swap, IIRC it is easy to do with the timing cover off like you were going to tab the KDP and tighten the hidden bolts.
cheers,
Douglas
__________________
1990 D250, NV5600, 16cm housing, PAC brake, TST Kit KDP tab, Powr-Lok'd 3.07, HX35....IC soon
1991 D250, 16cm housing
Douglas2 is offline   Quick reply to this message
Old 10-19-2010, 01:28 PM   #4 (permalink)
Cummins Enthusiast
 
rebeldodge1993's Avatar
 
Join Date: May 2010
Location: alvin, tx
Posts: 284
Thanks: 5
Thanked 7 Times in 7 Posts
iTrader Score: 0 reviews
well I am gonna pick up a oil pressure guage today and the pressure sending unit I wanna make good and sure my baby has oil to the top end and turbo but I have been looking and the original sender is a little loose and it spins ? but this morning it worked fine until I got to work I pushed the clutch in and it dropped to zero but the oil light or check engine light don't come on when it drops either

when I broke my last pressure sending unit the oil pressure dropped off the guage and all the lights come on but this time they don't come one it's weird
__________________
1993 d/w250 LE 5 speed & 4x4 conversion- s300, 4in custom exhaust, M&H timing spacer, BHAF, Denny T Pump top, Ptroke Coolertubz, 99 Pstroke intercooler, 366 spring, SDX 5x14's (140's) airdog 150gph, 3 piece manifold, pump tuned up and KDP tabbed
rebeldodge1993 is offline   Quick reply to this message
Old 10-19-2010, 01:32 PM   #5 (permalink)
Cummins Nut
 
SubliminalME's Avatar
 
Join Date: Dec 2009
Location: Princeton, NJ
Posts: 321
Thanks: 6
Thanked 13 Times in 13 Posts
iTrader Score: 0 reviews
When I was playing with my pump I set my idle too low and I'd constantly drop to 0 on the pressure gauge at idle. The gauges are just dummy lights anyhow...but if you've played with the idle, that could be it.
__________________
91.5 W250. 518-360 Swap, 12cm housing, Bosch 190s, Keldermann air ride.
SubliminalME is offline   Quick reply to this message
Old 10-19-2010, 04:22 PM   #6 (permalink)
Cummins Enthusiast
 
rebeldodge1993's Avatar
 
Join Date: May 2010
Location: alvin, tx
Posts: 284
Thanks: 5
Thanked 7 Times in 7 Posts
iTrader Score: 0 reviews
well this all started yesterday on my way home from work and I haven't done any adjustments at all and I have my pump idled up from stock cause it builds boost quicker but I'm gonna figure it out today and I'll post my findings
__________________
1993 d/w250 LE 5 speed & 4x4 conversion- s300, 4in custom exhaust, M&H timing spacer, BHAF, Denny T Pump top, Ptroke Coolertubz, 99 Pstroke intercooler, 366 spring, SDX 5x14's (140's) airdog 150gph, 3 piece manifold, pump tuned up and KDP tabbed
rebeldodge1993 is offline   Quick reply to this message
Old 10-19-2010, 10:10 PM   #7 (permalink)
1ST GEN MODERATOR
 
Philip's Avatar
 
Join Date: Nov 2007
Location: Indiana
Posts: 13,170
Thanks: 51
Thanked 1,407 Times in 1,154 Posts
iTrader Score: 9 reviews
Quote:
I changed the oil pressure switch out about a year ago
After market or OEM item???


Does the low oil pressure light come on also???
__________________
2014/93 W350 DRW, fuel pin turned, 6X.018" injectors, 4" exhaust, 3" air intake horn, Super HX40/16, G56 SBC Con-OFE, 3:07's axles, 2" skyjacker lift, B&W flatbed
Philip is offline   Quick reply to this message
Old 10-19-2010, 11:04 PM   #8 (permalink)
Cummins Enthusiast
 
rebeldodge1993's Avatar
 
Join Date: May 2010
Location: alvin, tx
Posts: 284
Thanks: 5
Thanked 7 Times in 7 Posts
iTrader Score: 0 reviews
no none of the lights come on at all when it drops it just pegs zero and builds back up after but I swapped it with one from napa and it seams to work good and it's back to normal takes a couple seconds to build up when I start it like usual I got an oil pressure guage in the passenger seat that I haven't installed but the dash is reading fine but i think it was just a junk part from oreillys last time... i don't really use much dealer items cause the nearest dealership is in Houston about an hour away and i hate Houston traffic and I'm pretty sure they hate me to for my smokeshows I leave them lol
__________________
1993 d/w250 LE 5 speed & 4x4 conversion- s300, 4in custom exhaust, M&H timing spacer, BHAF, Denny T Pump top, Ptroke Coolertubz, 99 Pstroke intercooler, 366 spring, SDX 5x14's (140's) airdog 150gph, 3 piece manifold, pump tuned up and KDP tabbed
rebeldodge1993 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 10:40 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2