New s466/83 no good after install!!! - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 4th Generation 2010 and up 6.7 Liter Cummins > 4th Gen Performance Parts Discussion
4th Gen Performance Parts Discussion Discussion of Performance Parts For the 4th Gen Trucks...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 03-23-2013, 03:46 PM   #1 (permalink)
Cummins Fan
 
2raptor5rider0's Avatar
 
Join Date: Aug 2010
Location: Centerville, TX
Posts: 93
Thanks: 7
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
New s466/83 no good after install!!!

did the 2nd gen swap and got my brand new borg warner s466/83 built buy fleece put in few days ago.i had the local shop install it,they had told me at first the turbos front fan (billit) came apart at start up,but they got thier story backwards somehow.come to find out while they were test driving it it happend.they said a few miles down the road they were goin up a hill an thats when it came apart.when i got it i checked for shaft play,i barley wiggled it but it would touch the side walls.im new on turbos but that just dont seem right.could it just have been a faulty one?
__________________
2010 6.7,mini maxx,5" tbe,7" dual stacks,s&b cai,deletes,wcc intake horn,120 ii nozzles,ARP 625's,fpe s466/83 with steed speed 2nd gen mani.
2raptor5rider0 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-23-2013, 04:09 PM   #2 (permalink)
Diesel Head
 
Thiago12/6.7's Avatar
 
Join Date: Apr 2012
Location: Houston, TX
Posts: 1,021
Thanks: 23
Thanked 150 Times in 112 Posts
iTrader Score: 1 reviews
Most likely they didnt install it correctly and messed it up, if they are changing stories...
__________________
2012 Dodge 2500 6.7 Mega Cab 4x4 Laramie .. Mini Maxx OD Tune, Isspro Gauges...5TBE...Egr Delete...Sinister TVD...Silencer Ring MIA....Leveled with 5100's...35x12.5x20 Toyo MT's...180T...Extreme Studs ....2012 Dyno run 399whp 4/13/13 454whp/956tq SOLD
Thiago12/6.7 is offline   Quick reply to this message
Old 03-23-2013, 04:19 PM   #3 (permalink)
rjp
WWW.SuncoastConverters.co
 
rjp's Avatar
 
Join Date: Jun 2009
Location: East Texas
Posts: 6,189
Thanks: 152
Thanked 1,066 Times in 836 Posts
iTrader Score: 1 reviews
Care to mention the shops name that did the install?
A change in the story is never the truth!!! I would guess they damaged it upon install and the damaged area decided to self destruct once in operation.
__________________
08Mega,4x4,68rfe, UNDER CONSTRUCTION,Big thanks to Ron@Suncoast& Erick@BrownsDiesel http://s772.photobucket.com/albums/yy10/ronniepene/
http://www.youtube.com/user/ronniepene1
WWW.SuncoastConverters.com
M3GA 68 Often Imitated but never Duplicated!! "Original Design" Tested Daily with high horsepower trucks!!

SUNCOAST CONVERTERS
rjp is offline   Quick reply to this message
Old 03-23-2013, 04:28 PM   #4 (permalink)
Cummins Nut
 
Join Date: Jan 2008
Location: Wyoming
Posts: 458
Thanks: 8
Thanked 47 Times in 36 Posts
iTrader Score: 0 reviews
If the bearings are toast that soon after install they probably forgot to pre lube it. Seen it happen more than twice on larger equipment.
__________________
'11 2500 Laramie
G56, Saddle Brown
coblanchard is offline   Quick reply to this message
Old 03-23-2013, 04:45 PM   #5 (permalink)
Diesel Head
 
Temple Diesel's Avatar
 
Join Date: Nov 2007
Location: Temple,TX
Posts: 2,884
Thanks: 267
Thanked 528 Times in 385 Posts
iTrader Score: 16 reviews
New s466/83 no good after install!!!

Did they have to remove compressor cover to install?
__________________
Thuren 3.0 Kings - Thuren 3" Coils - Thuren SB/TB/SS - Thuren Rear Bumper - Boogie Bumps - Patton Fab - DT Rad Arms - Carli Leafs & BJ's - RevMax VB - EFI
Temple Diesel is offline   Quick reply to this message
Old 03-23-2013, 04:51 PM   #6 (permalink)
Cummins Nut
 
carpenca's Avatar
 
Join Date: Dec 2010
Location: Indiana
Posts: 373
Thanks: 31
Thanked 167 Times in 89 Posts
iTrader Score: 0 reviews
You can see pictures of the compressor wheel and an explanation here...

2nd gen swap turbo choices = me useless and going nuts

Landon, its unfortunate this has happened. Truth of the matter is you are caught between a lie and an easy scape goat. Its easy to blame the turbo builder when you may hav developed a level of repore with your local shop. However this is a clear case of foreign object debris damage, and is not an issue caused by somthing Fleece Performance did or failed to do.

Yes the kits take time, as mentioned in the other thread, the majority of the lengthy time is caused by turn around rate of the Steed Speed manifold. We have yet to date been able to accumulate enough to just have sitting on the shelf to send out. As I said before the any short fall in communication is my fault, and I apologize for that.

We will let you know Monday what we can do to get this resolved.

Caleb
carpenca is offline   Quick reply to this message
Old 03-23-2013, 07:55 PM   #7 (permalink)
Cummins Nut
 
whitey70ss's Avatar
 
Join Date: Oct 2009
Location: PA
Posts: 304
Thanks: 41
Thanked 15 Times in 14 Posts
iTrader Score: 1 reviews
Wow from the pic there was some serious foreign matter bouncing around in your turbo.
__________________
'10 2500 CCSB-Mineral Grey-G56-Valair DD ceramic- Mini Maxx MCC tuned by Draconian Diesel-Steed Speed manifold-S465- ARP studs-100HP injectors-Floor It CP3-Fass 150-5"TBE-Leveled-Tinted-Bagged-N-FAB bars-35" Toyo MT's-Firestone riderite's
whitey70ss is offline   Quick reply to this message
Old 03-23-2013, 08:59 PM   #8 (permalink)
Diesel Freak
 
Fenn's Avatar
 
Join Date: Jun 2011
Posts: 917
Thanks: 171
Thanked 132 Times in 126 Posts
iTrader Score: 0 reviews
That sucks bud!
__________________
06 2500 mega cab, AFE CAI, 4" TBE, 50hp BMS sticks, 6" lift, 35" General grabbers
SOLD-2011 2500 6.7L
Fenn is offline   Quick reply to this message
Old 03-23-2013, 10:08 PM   #9 (permalink)
Cummins Nut
 
Join Date: Jan 2008
Location: Wyoming
Posts: 458
Thanks: 8
Thanked 47 Times in 36 Posts
iTrader Score: 0 reviews
After seeing the pic of the compressor wheel there was obviously something in the intake tubing when the engine was started.
The shop that installed it needs to step up and replace your turbo because of their fu** up.
__________________
'11 2500 Laramie
G56, Saddle Brown
coblanchard is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 05:37 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2