Erratic rail pressure, inconsistant power - Dodge Cummins Diesel Forum

3rd Gen. Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-18-2011, 11:48 AM Thread Starter
Diesel Head
 
Join Date: Aug 2007
Location: Shreveport, LA
Posts: 1,017
Thanks: 72
Thanked 72 Times in 53 Posts
iTrader Score: 1 reviews
Erratic rail pressure, inconsistant power

Hey guys, I was driving my new truck home last night and started to have some issues...

Cruising down the highway the truck just started to pop alittle and then power was cutting in and out. I noticed the rail pressure was dropping, then coming back up, and then finally just dropping out. at idle it was pretty choppy, and I was getting P0193 and P0123 codes, along with a fan code, transmission code, and a couple others that really had nothing to do with fueling or anything like that.

There was no hazing, white smoke or black smoke, no haze at idle or anything like that.

If I shut the truck down for 20min + and then fire it up it would seem to idle just fine and would drive for about 5-15 miles before it would act up again. I did this once and shut it down and had it flatbedded home.

It does have a quadzilla RP gauge in it that I am considering disconnecting, and trying to swap in my buddies rail pressure sensor and TPS to see if that changes anything. I am also going to try to hook up a pressure gauge to see what the FASS is putting to the CP3.

The truck has FLux 4 injectors, and Wicked Stage 3 pump. The pump and injectors have only about 5-7k miles on them. ( it has other supporting mods as well.)

The truck is running no tuning, I was using a smarty to read codes but it was vin locked so I could not download a tune.


Any help would be appreciated, as I am pretty new to the Common rail.


Thanks guys!


03 QCLB:S465/built auto/Flux 4's etc. SOLD
05 QCSB:S472/Stainless Diesel/Exergy etc. SOLD
07 SCLB: New drag truck project
barracuda_440 is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-18-2011, 11:56 AM
Diesel Head
 
mkwelds's Avatar
 
Join Date: Mar 2011
Location: Desert, CA
Posts: 1,925
Thanks: 207
Thanked 203 Times in 186 Posts
iTrader Score: 3 reviews
Check out the lift pump pressure like ur planning to could be that. Other options r replace the fca, pressure sensor on the rail, or the prv on the rail.

2004.5 3500 4x4 NV5600, PDR Cam, ARP 425s, industrial injection 60 horse injectors, Raptor 100 fuel pump, DIY 2micron fuel filter system with big line upgrade, HE351 over S475,more brewing SMARTY S06 and UDC fine tuning all of it
mkwelds is offline  
post #3 of 6 (permalink) Old 07-18-2011, 11:58 AM
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,925
Thanks: 0
Thanked 1,736 Times in 1,305 Posts
iTrader Score: 7 reviews
disconnect all gauges and boxes from the rail pressure sensor circuit and go for a drive, see if it still does it.

From what you're describing, (and following facebook.. 2003 truck right???) I'd say you need a new APPS. Especially with that P0123 code..

Timbo APPS

Back in the common snail game. 03 SO 2wd 480,000 miles and counting.
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49. RACEME 07-09 Delete Tuners
Shibbyutman is offline  
post #4 of 6 (permalink) Old 07-18-2011, 12:18 PM Thread Starter
Diesel Head
 
Join Date: Aug 2007
Location: Shreveport, LA
Posts: 1,017
Thanks: 72
Thanked 72 Times in 53 Posts
iTrader Score: 1 reviews
Thanks Kurt! and yes its that 2003.

I am going to swap my buddies Rail pressure sensor in it, and TPS, and maybe the APPS too, one at a time to see if any one solves the issue.

03 QCLB:S465/built auto/Flux 4's etc. SOLD
05 QCSB:S472/Stainless Diesel/Exergy etc. SOLD
07 SCLB: New drag truck project
barracuda_440 is offline  
post #5 of 6 (permalink) Old 07-18-2011, 12:23 PM
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,925
Thanks: 0
Thanked 1,736 Times in 1,305 Posts
iTrader Score: 7 reviews
Let us know how it works out. If you have the parts to switch thats the best way to do it.

Back in the common snail game. 03 SO 2wd 480,000 miles and counting.
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49. RACEME 07-09 Delete Tuners
Shibbyutman is offline  
post #6 of 6 (permalink) Old 07-18-2011, 02:37 PM Thread Starter
Diesel Head
 
Join Date: Aug 2007
Location: Shreveport, LA
Posts: 1,017
Thanks: 72
Thanked 72 Times in 53 Posts
iTrader Score: 1 reviews
Wont be a few more hours until I can tear into it, but anyone else have any advice or input?

03 QCLB:S465/built auto/Flux 4's etc. SOLD
05 QCSB:S472/Stainless Diesel/Exergy etc. SOLD
07 SCLB: New drag truck project
barracuda_440 is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome