Code P0336? - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 3rd Gen. Dodge Cummins 03-07 Common Rail Forums > 3rd Gen. Powertrain
3rd Gen. Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 04-11-2011, 04:18 PM   #1 (permalink)
Diesel Freak
 
Join Date: Feb 2011
Posts: 621
Thanks: 1
Thanked 12 Times in 11 Posts
iTrader Score: 0 reviews
Code P0336?

I was wandering if having old batteries and bad corrosion would cause this code maybe because of low volts maybe or do i need to replace my crankshaft position sensor.
__________________
2001 dodge cummins 5 speed 4x4, extcab shortbed, white, 5 inch exhaust, moto metal 951's, new injection pump and raptor 100 ,autometer gauges fuel,egt,boost, edge drag comp, bd stealth plate, southbend clutch.
white04dodgecummins is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-11-2011, 04:29 PM   #2 (permalink)
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,875
Thanks: 0
Thanked 1,701 Times in 1,285 Posts
iTrader Score: 7 reviews
are you running a chip or box on the truck? TST, and Banks will both occasionally cause that code.
__________________
Juanita has been SOLD!
2003 QCLB 2500 640 HP / 1125 ft/lbs SOLD!
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49.
Shibbyutman is offline   Quick reply to this message
Old 04-11-2011, 05:20 PM   #3 (permalink)
Diesel Freak
 
Join Date: Feb 2011
Posts: 621
Thanks: 1
Thanked 12 Times in 11 Posts
iTrader Score: 0 reviews
Nope my truck is bone stock.
__________________
2001 dodge cummins 5 speed 4x4, extcab shortbed, white, 5 inch exhaust, moto metal 951's, new injection pump and raptor 100 ,autometer gauges fuel,egt,boost, edge drag comp, bd stealth plate, southbend clutch.
white04dodgecummins is offline   Quick reply to this message
Old 04-11-2011, 05:38 PM   #4 (permalink)
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,875
Thanks: 0
Thanked 1,701 Times in 1,285 Posts
iTrader Score: 7 reviews
Have you ever had a belt come off? Or any road debris kick up?

That sensor is kinda out in the open on the bottom of the motor and is susceptible to both of those.
__________________
Juanita has been SOLD!
2003 QCLB 2500 640 HP / 1125 ft/lbs SOLD!
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49.
Shibbyutman is offline   Quick reply to this message
Old 04-11-2011, 05:49 PM   #5 (permalink)
Diesel Freak
 
Join Date: Feb 2011
Posts: 621
Thanks: 1
Thanked 12 Times in 11 Posts
iTrader Score: 0 reviews
no i have never had a belt come off sense i have owned the truck the code just popped up the other day when i pulling my tractor up a hill and the my check engine light came on and the code p0336 came up?
__________________
2001 dodge cummins 5 speed 4x4, extcab shortbed, white, 5 inch exhaust, moto metal 951's, new injection pump and raptor 100 ,autometer gauges fuel,egt,boost, edge drag comp, bd stealth plate, southbend clutch.
white04dodgecummins is offline   Quick reply to this message
Old 04-11-2011, 05:50 PM   #6 (permalink)
Diesel Freak
 
Join Date: Feb 2011
Posts: 621
Thanks: 1
Thanked 12 Times in 11 Posts
iTrader Score: 0 reviews
I also have P0191 code and a P2607 code.
__________________
2001 dodge cummins 5 speed 4x4, extcab shortbed, white, 5 inch exhaust, moto metal 951's, new injection pump and raptor 100 ,autometer gauges fuel,egt,boost, edge drag comp, bd stealth plate, southbend clutch.
white04dodgecummins is offline   Quick reply to this message
Old 04-11-2011, 06:08 PM   #7 (permalink)
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,875
Thanks: 0
Thanked 1,701 Times in 1,285 Posts
iTrader Score: 7 reviews
P2607 Category Powertrain Definition Intake Air Heater "B" Circuit Low

You have a relay or element that is bad in your grid heater... most likely a relay.

P0191 Category Powertrain Definition Fuel Rail Pressure Sensor "A" Circuit Range/Performance

This can be caused by a dirty fuel filter or a bad rail pressure sensor if it comes back repeatedly.

Does your truck ever give a hard crank to get it started or does it always just fire right up? Usually when a crankshaft angle sensor starts to go out, you'll have long cranking times or hard starting.
__________________
Juanita has been SOLD!
2003 QCLB 2500 640 HP / 1125 ft/lbs SOLD!
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49.
Shibbyutman is offline   Quick reply to this message
Old 04-11-2011, 07:45 PM   #8 (permalink)
Diesel Freak
 
Join Date: Feb 2011
Posts: 621
Thanks: 1
Thanked 12 Times in 11 Posts
iTrader Score: 0 reviews
Well Every once in a while i will start the truck and it will take about 3 seconds to fire up. sometimes which is annoying. also my fuel filter only has about 600 miles on it.
__________________
2001 dodge cummins 5 speed 4x4, extcab shortbed, white, 5 inch exhaust, moto metal 951's, new injection pump and raptor 100 ,autometer gauges fuel,egt,boost, edge drag comp, bd stealth plate, southbend clutch.
white04dodgecummins is offline   Quick reply to this message
Old 04-11-2011, 07:50 PM   #9 (permalink)
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,875
Thanks: 0
Thanked 1,701 Times in 1,285 Posts
iTrader Score: 7 reviews
I'd say that warrants an inspection anyway. Take the crankshaft angle sensor out and clean it off, clean the mounting ear off that it mounts to and the connector really well.

You'll be looking for cracks or nicks of any kind on the sensor head.
__________________
Juanita has been SOLD!
2003 QCLB 2500 640 HP / 1125 ft/lbs SOLD!
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49.
Shibbyutman is offline   Quick reply to this message
Old 04-11-2011, 08:19 PM   #10 (permalink)
Diesel Freak
 
Join Date: Feb 2011
Posts: 621
Thanks: 1
Thanked 12 Times in 11 Posts
iTrader Score: 0 reviews
ok thank you very much.
__________________
2001 dodge cummins 5 speed 4x4, extcab shortbed, white, 5 inch exhaust, moto metal 951's, new injection pump and raptor 100 ,autometer gauges fuel,egt,boost, edge drag comp, bd stealth plate, southbend clutch.
white04dodgecummins is offline   Quick reply to this message
Old 04-12-2011, 02:01 AM   #11 (permalink)
Newbie
 
Join Date: Apr 2008
Location: Spangle, Wa
Posts: 34
Thanks: 0
Thanked 3 Times in 3 Posts
iTrader Score: 0 reviews
Like Shibby said road debris can get on it and cause it to miss read or even a cord from the belt can fray off and whack the CPS and damage it. Try taking it off and cleaning the face. Also look at your balancer. If it is wobbling it could also set off a P0336. I bought a new crank position sensor when I started throwing the P0336 code and a month later the code came back. It ended up being that the bolts holding the balancer to the crank had loosened up causing the balancer to wobble, also causing the balancer bolt holes to oval out. Bought a replacement balancer and hone ring from a junk yard for $100 and problem solved.
__________________
05 3500SRW 4Dr Long Bx 4x4, NV5600, S&B Air intake, 4" turbo back, SB clutch, Smarty Jr, 60hp injectors, BD Super B, Edge CTS, GDP 2micron, 420k Miles roll'n.
baru is offline   Quick reply to this message
Old 04-13-2011, 01:09 PM   #12 (permalink)
Newbie
 
Join Date: Feb 2008
Posts: 9
Thanks: 4
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I sort of got the same problem right now and have a new crank sensor to put in. Unfortunately I'm not quite sure how to remove it. There is a red tab on bottom to push out of way however it still seems stuck. I have noticed a black cap on top where wire comes in but not sure if have to turn/push, etc. Didn't want to break it.

Anyone know how to remove it out of wire harness?

[IMG][/IMG]
__________________

ED VR

Last edited by EdVR; 04-13-2011 at 01:20 PM. Reason: Picture didn't work
EdVR is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 06:52 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2