4x4 Indicator Light Not Working - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 3rd Gen. Dodge Cummins 03-07 Common Rail Forums > 3rd Gen. Powertrain
3rd Gen. Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 11-01-2010, 05:48 AM   #1 (permalink)
Cummins Fanatic
 
Join Date: Dec 2007
Posts: 121
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 1 reviews
4x4 Indicator Light Not Working

I have a manual shift 4x4 and when I put it in 4x4 the indicator light in the dash no longer lights up. I thought it might be the bulb so I replaced all the bulbs in the instrument panel and the light still does not appear. Does anyone else know what it might be? Thanks!\

Also the trucks does go in 4x4 and it works, its just the light does not appear when its in 4x4.
__________________
2005 Dodge Ram 2500 4x4 SLT QC, Auto, 5" Turbo Back FBD Exhaust, AFE Stage 2 CAI, Danin Optix EGT, Tranny, Fuel, and Boost gauges, Smarty Jr....
Hamdog16 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-01-2010, 09:39 AM   #2 (permalink)
Newbie
 
Join Date: May 2010
Posts: 15
Thanks: 1
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
i was gonna start a thread and ask why my truck didnt have a 4wd light ,cause i def dont see one when i engauge it. I notice it the other day but i not sure if i comes with one on 04 5.9 auto
rodknock02 is offline   Quick reply to this message
Old 11-01-2010, 09:45 AM   #3 (permalink)
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,875
Thanks: 0
Thanked 1,701 Times in 1,285 Posts
iTrader Score: 7 reviews
there is a position switch on the transfercase that is supposed to tell the cluster when it grabs 4x4. I'd imagine if that switch is out of adjustment or broken it wouldn't turn on.

I have the shift on the fly transfercase in my truck and my light in the dash blinks on and off when it wants too while in 4x4
__________________
Juanita has been SOLD!
2003 QCLB 2500 640 HP / 1125 ft/lbs SOLD!
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49.
Shibbyutman is offline   Quick reply to this message
Old 11-01-2010, 10:10 AM   #4 (permalink)
Cummins Fanatic
 
Join Date: Dec 2007
Posts: 121
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 1 reviews
Do you know where that is located on the transfer case So I can take a look at it?

Thanks!
__________________
2005 Dodge Ram 2500 4x4 SLT QC, Auto, 5" Turbo Back FBD Exhaust, AFE Stage 2 CAI, Danin Optix EGT, Tranny, Fuel, and Boost gauges, Smarty Jr....
Hamdog16 is offline   Quick reply to this message
Old 11-01-2010, 10:25 AM   #5 (permalink)
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,875
Thanks: 0
Thanked 1,701 Times in 1,285 Posts
iTrader Score: 7 reviews
Look for something with a harness going to it Shouldn't be many things there since yours is a manual version. I'd expect it to be somewhere in the middle of the case and not near the output shaft.
__________________
Juanita has been SOLD!
2003 QCLB 2500 640 HP / 1125 ft/lbs SOLD!
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49.
Shibbyutman is offline   Quick reply to this message
Old 11-02-2010, 01:14 AM   #6 (permalink)
Cummins Fanatic
 
710Burner's Avatar
 
Join Date: May 2009
Location: South Texas
Posts: 122
Thanks: 20
Thanked 11 Times in 10 Posts
iTrader Score: 0 reviews
I'm in the same boat. Got my '05 a week ago. I guess I need to crawl under again and start poking around with the switch on the transfer case.
__________________
2005 Quad Cab 4WD 3500 SRW, G56, Ranch Hand FRE, silencer ring delete, new injectors from T&C Diesel at 101K miles, Airdog II inside the frame, Maxx Links & Energy Suspension bushings
710Burner is offline   Quick reply to this message
Old 11-02-2010, 01:26 AM   #7 (permalink)
Diesel Freak
 
Join Date: Dec 2007
Location: Greater Denver region
Posts: 736
Thanks: 23
Thanked 52 Times in 50 Posts
iTrader Score: 0 reviews
I think there's only 1 harness on the manual transfer case. I just had mine out last week and that's all it had. It was on the top front driver's side near where the linkage attaches. It's a 2 wire harness.
lackskill is offline   Quick reply to this message
Old 11-02-2010, 06:37 AM   #8 (permalink)
Cummins Fanatic
 
Join Date: Dec 2007
Posts: 121
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 1 reviews
Is it the two wire harness that plugs into the top of the transmission? I took that off and carefully inspected and cleaned it up but the light still does not turn on. What do I have to do to replace this sensor? thanks!
__________________
2005 Dodge Ram 2500 4x4 SLT QC, Auto, 5" Turbo Back FBD Exhaust, AFE Stage 2 CAI, Danin Optix EGT, Tranny, Fuel, and Boost gauges, Smarty Jr....
Hamdog16 is offline   Quick reply to this message
Old 11-02-2010, 07:44 AM   #9 (permalink)
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,875
Thanks: 0
Thanked 1,701 Times in 1,285 Posts
iTrader Score: 7 reviews
I don't think a 4 wheel drive indicator light sender would be on the transmission. The transmission wouldn't know if or when the transfer case is in 4x4.

I suspect, though don't know for sure, that it is a position sensor that may be a pin and detent style where something actually pushes on a pin, or it is a magnetic pickup style where something ferrous based runs in front of it when it is in 4x4 and it is supposed to pick that up.

If it is the magnetic style those type of sensors crap out all the time, they are kinda similar to wheel speed sensors that die all the time on our trucks. If they aren't too much you may just want to swap in a new sensor and see what happens.
__________________
Juanita has been SOLD!
2003 QCLB 2500 640 HP / 1125 ft/lbs SOLD!
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49.
Shibbyutman is offline   Quick reply to this message
Old 11-02-2010, 03:37 PM   #10 (permalink)
Newbie
 
Join Date: Feb 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
My 04 did the same thing. Mine turned out to be the wireing harness at the transher case switch had lost its ground. We installed an external ground and that fixed it.
__________________
04 4x4, 3.73 gears,Auto,Snug top cap. AEM.Smarty.
my04rattler is offline   Quick reply to this message
Old 11-02-2010, 03:56 PM   #11 (permalink)
Diesel Freak
 
Join Date: Dec 2007
Location: Greater Denver region
Posts: 736
Thanks: 23
Thanked 52 Times in 50 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by Hamdog16 View Post
Is it the two wire harness that plugs into the top of the transmission? I took that off and carefully inspected and cleaned it up but the light still does not turn on. What do I have to do to replace this sensor? thanks!
The transfer case bolts to the tail end of the transmission, but yes it is a 2 wire harness as shown in the pic below, right behind the transfer case vent tube.



I stole that pic from one of the 48re R&R threads. I hope the OP doesn't mind.
lackskill is offline   Quick reply to this message
Old 11-02-2010, 04:09 PM   #12 (permalink)
Diesel Freak
 
Starchief_59's Avatar
 
Join Date: Aug 2010
Location: Canyon Lake, Texas
Posts: 866
Thanks: 0
Thanked 20 Times in 20 Posts
iTrader Score: 0 reviews
There's only one on the T case. It's on the driver's side on the top.
__________________
Robert "R2" Lewis
1991 W250 single cab 5 speed- looking for front dually hubs
Starchief_59 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 05:21 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2