new cp3, new lift pump still no start.. but if i spray ether it starts.. need help!!! - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 3rd Gen. Dodge Cummins 03-07 Common Rail Forums > 3rd Gen. Powertrain
3rd Gen. Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 01-27-2010, 06:47 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2010
Location: nj
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
new cp3, new lift pump still no start.. but if i spray ether it starts.. need help!!!

i have a 2003 3500... i got in to my truck to go to work one day and it started to take a long time cranking but it than started. day after day it got longer and longer to start... now doesent start at all only if i recycle the key like 4 times cranks a while than starts. i changed the lifter pump. cp3 (injector pump) and filter...when i first put the cp3 in it started right up no prob after i let it run to get the air out i shut it off and it went back to long cranking... people told me i might have a hole somewhere, or i have bad injectors, or its a pressure relief valve...idk what it could b and the last thing i want to to go back to the dealer...please help i spent wayyy to much $ and its just sittin there...
tommy smoke stax is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-27-2010, 06:51 PM   #2 (permalink)
Diesel Freak
 
Join Date: Dec 2006
Location: Ontario
Posts: 697
Thanks: 56
Thanked 40 Times in 39 Posts
iTrader Score: 2 reviews
what lift pump did you put in?
what CP3 pump did you put in?
why did you change out those items first?
reason i ask is that it sounds more like injectors, but will need more info on your truck. like mileage?
did someone point you in that direction to have those pieces changed?
should really get a flow return test done, or send the injectors out to a shop who can test them/fix them/ rebuild them
__________________
04,3500,auto,silver Quad,4x4,sps62,5"magnaflow,suncoast,Fass,smarty TNT,TST,gauges,mag hytec diffs and trans covers,air bags,amp reasearch,FF front bumper,methods,37"toyo MT,5"lift,ATS flares,CFM intake,coolant bp
waiting to go on, head studs,fluid damper,twins,TC rail,air boss,
pullinhard is offline   Quick reply to this message
Old 01-27-2010, 07:04 PM   #3 (permalink)
Newbie
 
Join Date: Jan 2010
Location: nj
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
everything is stock.. stock lift pump, stock cp3... i have about 140,000 miles on it..
tommy smoke stax is offline   Quick reply to this message
Old 01-27-2010, 07:08 PM   #4 (permalink)
CF Administration
 
THE STIG's Avatar
 
Join Date: Nov 2008
Location: Behind the wheel somewhere.
Posts: 9,994
Thanks: 1,128
Thanked 3,549 Times in 1,738 Posts
iTrader Score: 6 reviews
why did you change the lift pump and cp3? Sounds like an injector issue to me
__________________
Powerful - Reliable - Inexpensive. Pick any two at a time, the third is not included.


Need an old thread unlocked? PM ANY Moderator or Admin with a link and request to bump the thread. Old threads time out and auto-close.

Are you a vendor interested in sponsoring one of our Ride Of The Month contests in exchange for free home page advertising? PM me!
THE STIG is offline   Quick reply to this message
Old 01-27-2010, 07:08 PM   #5 (permalink)
Diesel Head
 
TXAustin's Avatar
 
Join Date: Nov 2009
Location: Dallas/East TX
Posts: 2,538
Thanks: 20
Thanked 254 Times in 192 Posts
iTrader Score: 4 reviews
IMHO it sounds like you either have a leak somewhere or a bad injector(s). Common problem on the CRs.

Have a flow return test, and hook up a rail pressure gauge to see what you are putting out.
__________________
[04.5 QCSB] Jeff Garmon's Fat Shaft billet 48RE, 6" superlift, 37" Toyo M/T, XD Monsters, Super B Special/ S480 race cover, ATS twin pumps, II 65lpm (~250hp), ARP, Smarty SSR, AirDog 150, TC rail, 25k / 27k PRV's, Rail/fuel/EGT/boost/throttle%/load% gauges, Flex-a-Lite, 6" MBRP stacks, grid delete
TXAustin is offline   Quick reply to this message
Old 01-27-2010, 07:12 PM   #6 (permalink)
Newbie
 
Join Date: Jan 2010
Location: nj
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
great more money to dish out...lol...doesent injectors cost like 150$ a peace? i hope the they can fix the stock ones...lol
tommy smoke stax is offline   Quick reply to this message
Old 01-27-2010, 07:16 PM   #7 (permalink)
TECH SPECIALIST
 
steelhead01's Avatar
 
Join Date: Nov 2007
Posts: 4,984
Thanks: 363
Thanked 802 Times in 658 Posts
iTrader Score: 0 reviews
that dealer shop has milked you dry.
stay away from them.

since you have no diesel mechanical knowledge take it to your local hot trucks shop that specializes in Dodge/Cummins.
get references on your states forum here
will save you money and headaches in the end. can destroy the engine running it low rail pressure lean on diesel or leaking injectors that dump diesel into the crank case.

get your engine parts from a authorized Cummins listed dealer, half the price of rip off Chrysler Corp. and you're certain to get real made by Cummins parts, not some Oriental pot metal knockoff that violates patent laws and is not tested

real Bosch HPCR new FIs for $150 a piece is only in fairy tales, the cheap ones on ebay are made from Chinese noodles.

cliff


Quote:
Originally Posted by tommy smoke stax View Post
i have a 2003 3500... i got in to my truck to go to work one day and it started to take a long time cranking but it than started. day after day it got longer and longer to start... now doesent start at all only if i recycle the key like 4 times cranks a while than starts. i changed the lifter pump. cp3 (injector pump) and filter...when i first put the cp3 in it started right up no prob after i let it run to get the air out i shut it off and it went back to long cranking... people told me i might have a hole somewhere, or i have bad injectors, or its a pressure relief valve...idk what it could b and the last thing i want to to go back to the dealer...please help i spent wayyy to much $ and its just sittin there...
__________________
Funniest question&response on here
AH64ID: Is your kitty in place?
TONASKET:You callin me a *****???

Last edited by steelhead01; 01-27-2010 at 07:21 PM.
steelhead01 is offline   Quick reply to this message
Old 01-27-2010, 07:17 PM   #8 (permalink)
Cummins Nut
 
jjrightmire1973's Avatar
 
Join Date: Jul 2008
Location: Crockett, Texas
Posts: 407
Thanks: 3
Thanked 7 Times in 7 Posts
iTrader Score: 0 reviews
Cheapest place I have found injectors is $260.00 each plus $80.00 core charge
__________________
2003 H.O 543 HP and 1273 torque before Stage 3 pump and beta 4.2
jjrightmire1973 is offline   Quick reply to this message
Old 01-27-2010, 10:00 PM   #9 (permalink)
Newbie
 
Join Date: Sep 2009
Location: Boerne Texas
Posts: 44
Thanks: 1
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Quote:
Originally Posted by jjrightmire1973 View Post
Cheapest place I have found injectors is $260.00 each plus $80.00 core charge
WHERE! WHERE!
__________________
2003, 2500 2WD, AMSOIL Stock, 26 Years USAF still going!
HillCountry is offline   Quick reply to this message
Old 01-27-2010, 11:07 PM   #10 (permalink)
Diesel Freak
 
Join Date: Dec 2006
Location: Ontario
Posts: 697
Thanks: 56
Thanked 40 Times in 39 Posts
iTrader Score: 2 reviews
every time i read your replies,( steelhead01) i can't help but laugh. you have a way with words!!!!
but make perfect sense
injectors are pricey, but not as pricey as replacing a motor.
thats why i ask why you chaged out that stuff first.
i had a buddy with similar problems, he took it to 6 different dealerships, all in which took his money and replaced stupid stuff without testing anything. needless to say, he had a no start, unless using starting fluid. i replaced injectors for him, and fixed his problem, but it was after he spent way too much money on needless items. first dealer should have done some test to see that the injectors were wore out and were returning too much fuel back, and not letting it get to the psi required to start the engine.
__________________
04,3500,auto,silver Quad,4x4,sps62,5"magnaflow,suncoast,Fass,smarty TNT,TST,gauges,mag hytec diffs and trans covers,air bags,amp reasearch,FF front bumper,methods,37"toyo MT,5"lift,ATS flares,CFM intake,coolant bp
waiting to go on, head studs,fluid damper,twins,TC rail,air boss,
pullinhard is offline   Quick reply to this message
Old 01-28-2010, 12:38 AM   #11 (permalink)
DELETE YOUR TURBO!!!!!
 
WATERLOO49's Avatar
 
Join Date: Jan 2009
Location: Nebraska
Posts: 2,435
Thanks: 230
Thanked 673 Times in 236 Posts
iTrader Score: 4 reviews
injector is byppassing guarenteed if it will pop off with a huff of either you have an injector that wont let it build rail pressure xtreme diesel has good prices on replacements
__________________
YOUR DREAM TRUCK
TURBO-Deleted
INJECTORS-500hp
CHIPS-STACKED PRINGLES AND A DORITO
PERFORMANCE XTRAS-Flux capacitor, custom cut silencer ring, twin smoke switches
Body- wal mart chrome, 20" stacks, 500hp stickers
ALL SMOKE AND NO GO THE ONLY WAY TO ROLL!!
NEBRASKA DIESEL CREW PRESIDENT/WATERLOO FIRE DEPT
WATERLOO49 is offline   Quick reply to this message
Old 01-28-2010, 03:13 AM   #12 (permalink)
TECH SPECIALIST
 
steelhead01's Avatar
 
Join Date: Nov 2007
Posts: 4,984
Thanks: 363
Thanked 802 Times in 658 Posts
iTrader Score: 0 reviews
hell, what am i doing wrong.
they don't give me 6 chances at the craps tables in Vegas.

What LIES the Dealer tells you and all the cash you dump at a Dodge dealer stay in the Dealer


"""""""he took it to 6 different dealerships, all in which took his money and replaced stupid stuff without testing anything. needless to say, he had a no start, unless using starting fluid. i replaced injectors for him, and fixed his problem, but it was after he spent way too much money on needless items. first dealer should have done some test to see that the injectors were wore out and were returning too much fuel back, and not letting it get to the psi required to start the engine.
__________________
Funniest question&response on here
AH64ID: Is your kitty in place?
TONASKET:You callin me a *****???
steelhead01 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 07:49 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2