signs of cp3 and injector failure/going bad - Dodge Cummins Diesel Forum
3rd Gen. Performance Parts Discussion Discussion of Performance Parts For the 3rd Gen Trucks No Advertising ...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-04-2011, 11:33 PM Thread Starter
Cummins Nut
 
ballewCTD04's Avatar
 
Join Date: Mar 2009
Location: north myrtle beach, sc
Posts: 456
Thanks: 12
Thanked 12 Times in 12 Posts
iTrader Score: 0 reviews
signs of cp3 and injector failure/going bad

got a good bit of miles on my injectors and cp3 and just wondering what are some signs of them going bad besides white smoke and hard start.


Early 04-Suncoast tranny, 64/65/12, Raptor150, Smarty TNT/R, pusher, Blox CAI/W velocity stack, MBRP, Dipricol Optix-tranny,EGT,Boost, 20x12's
ballewCTD04 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-04-2011, 11:36 PM
Diesel Head
 
Join Date: Feb 2008
Location: Peoria IL
Posts: 3,695
Thanks: 641
Thanked 643 Times in 495 Posts
iTrader Score: 1 reviews
shake, lots of smoke or more smoke than usual, bad fuel economy, loss of power. the big thing seams to be an off balance idle or a shake at idle. I have heard a good rule of thub is to open your driver door with the truck ideling in park, if you open door which is hanging freely is shaking alot, thats a good sign of an off balanced engine.

2014 2500 Black Appearance Package big horn CTD 4x4.
Thuren suspension, Rigid 30 inch e series, rear air.
MPD106 is offline  
post #3 of 6 (permalink) Old 01-04-2011, 11:40 PM Thread Starter
Cummins Nut
 
ballewCTD04's Avatar
 
Join Date: Mar 2009
Location: north myrtle beach, sc
Posts: 456
Thanks: 12
Thanked 12 Times in 12 Posts
iTrader Score: 0 reviews
hmm not really noticed any excess shake or anything on the lines of that, but sometimes i do think when i accelerate my smoke is less black than it use to be. I might just be crazy but i bought the truck at 150k miles and it now has 220k.

Early 04-Suncoast tranny, 64/65/12, Raptor150, Smarty TNT/R, pusher, Blox CAI/W velocity stack, MBRP, Dipricol Optix-tranny,EGT,Boost, 20x12's
ballewCTD04 is offline  
post #4 of 6 (permalink) Old 01-05-2011, 12:02 PM
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,924
Thanks: 0
Thanked 1,733 Times in 1,304 Posts
iTrader Score: 7 reviews
ticking, my old set of injectors had a definite tick to them just before I switched them out. it would be intermittent, all the time cold, sometimes when hot. If you have a rail pressure gauge and you've been watching it fairly closely I noticed my rail pressure numbers getting worse and worse and worse as the injectors leaked off more and more flow. I went from 90's to 120's and GAINED rail pressure. My truck always had a haze just before I pulled the injectors in it. Not so much at an idle, but at any load I could see a bit of black coming out of the stacks at all times.

Back in the common snail game. 03 SO 2wd 480,000 miles and counting.
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49. RACEME 07-09 Delete Tuners
Shibbyutman is offline  
post #5 of 6 (permalink) Old 01-05-2011, 12:52 PM Thread Starter
Cummins Nut
 
ballewCTD04's Avatar
 
Join Date: Mar 2009
Location: north myrtle beach, sc
Posts: 456
Thanks: 12
Thanked 12 Times in 12 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by Shibbyutman View Post
ticking, my old set of injectors had a definite tick to them just before I switched them out. it would be intermittent, all the time cold, sometimes when hot. If you have a rail pressure gauge and you've been watching it fairly closely I noticed my rail pressure numbers getting worse and worse and worse as the injectors leaked off more and more flow. I went from 90's to 120's and GAINED rail pressure. My truck always had a haze just before I pulled the injectors in it. Not so much at an idle, but at any load I could see a bit of black coming out of the stacks at all times.
Ahhh well looks like I might be heading in that direction then. When I am driving I get a slight ticking almost like I got to much "timing" on my motor if you know what I mean, but this started about 2weeks ago without touching the smarty.

Early 04-Suncoast tranny, 64/65/12, Raptor150, Smarty TNT/R, pusher, Blox CAI/W velocity stack, MBRP, Dipricol Optix-tranny,EGT,Boost, 20x12's
ballewCTD04 is offline  
post #6 of 6 (permalink) Old 01-05-2011, 01:06 PM
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,924
Thanks: 0
Thanked 1,733 Times in 1,304 Posts
iTrader Score: 7 reviews
yup, mine just kinda showed up one day and never left (until the new injectors went in).

Back in the common snail game. 03 SO 2wd 480,000 miles and counting.
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49. RACEME 07-09 Delete Tuners
Shibbyutman is offline  
Sponsored Links
Advertisement
 
Closed Thread
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome