2013 2500, TPS and Tranny Issues - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 4th Generation 2010 and up 6.7 Liter Cummins > 2013+ General Discussion
2013+ General Discussion General Chit Chat About the 2013 model year differences 6.7L 4th generation Cummins - NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Reply
 
LinkBack Thread Tools Display Modes
Old 05-22-2013, 02:39 AM   #1 (permalink)
Cummins Fan
 
DPeglow's Avatar
 
Join Date: May 2013
Location: Las Vegas, NV
Posts: 99
Thanks: 15
Thanked 22 Times in 16 Posts
iTrader Score: 0 reviews
2013 2500, TPS and Tranny Issues

I bought my truck the begining of May, and i'm taking it back to the dealership friday for the second time.

Initially it was for 3 reasons.
1. Alignment was off and it pulled to the Right
2. Tire Pressure System was erratic (Varied 5-10#s daily and I've got Nitrogen in the tires)
3. The radio would turn on when you turned the truck off. Well more like your driving with the radio off, pull in the drive way, and turn the key off and the radio came on, then opened the door and it turned back off.

Pick it up that evening and they tell me They fixed the alignment, reset the TPS, and put a service bulletin in at Chrystler for a fix on the radio (said they've never seen anything like it)

On the drive home, alignment is still off. Doesnt pull as bad but still pulls to the right, and when they did the alignment they didnt center the steering wheel because its off center now too.
TPS is still all over the place.

Called back to scehd another appointment, and service writer says the TPS issue should be fixed with the radio issue when Chrystler releases a new 'flash' for the computer. And to bring it back in and they'll do the alignment again.

But now I feel like the tranny is having some issues. Seems like it slips alot before shifting between what I think is 3rd and 4th at about 35MPH and sometimes then slams into 4th gear. Also other times after accelerating to 35-45 MPH and letting off the throttle and then getting back on it theres a 'clunk' from the drivetrain. Its an auto btw.

Anyone else having these issues?
DPeglow is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-22-2013, 08:05 AM   #2 (permalink)
Diesel Head
 
ranchertx's Avatar
 
Join Date: Mar 2011
Posts: 1,554
Thanks: 99
Thanked 437 Times in 272 Posts
iTrader Score: 0 reviews
Bet you have a bad belt on a front tire. Try switching sides and see if it pulls to the left.
__________________
2013 Ram 3500 DRW 6.7 Cummins Aisin, Laramie 4X4
2001 Ram 2500 Ext Cab 5.9 Cummins SLT 4X4
1993 Dodge Ram 5.9 4X4 Reg Cab
ranchertx is offline   Reply With Quote Quick reply to this message
Old 05-22-2013, 02:11 PM   #3 (permalink)
Diesel Freak
 
Join Date: Dec 2007
Posts: 625
Thanks: 6
Thanked 152 Times in 103 Posts
iTrader Score: 0 reviews
Time to find a different dealer if they couldn't manage to align it properly.
Lead Head is offline   Reply With Quote Quick reply to this message
Old 05-22-2013, 02:47 PM   #4 (permalink)
Cummins Fan
 
Join Date: Nov 2007
Location: Traverse City Michigan
Posts: 74
Thanks: 12
Thanked 14 Times in 10 Posts
iTrader Score: 0 reviews
On my 2010 2wd the dealer did 3 alignments under wrnty, paid for a set of tires, and still never got it correct.

Tired of wasting my time, I went to firestone and bought a LIFETIME alignment, first time they got it perfect! Amazing how that works some times.

So sorry to hear about your problems, keep good documentation in case you need to lemon law the sucker. Its a machine, and any machine can have problems. Sucks, cause we all love our cummins rams, but nothings perfect.

Good luck
__________________
2013 RCLB 2WD G56, Previous 2010 RCLB 2WD G56, 2007.5 CCLB DRW 4x4, 2003 CCSB 4x4, 2003 RCLB 2WD, Hauling, 51' Gooseneck Car Hauler, 36' Cigarette "Unleashed".
TOOLMAN is offline   Reply With Quote Quick reply to this message
Old 05-22-2013, 04:02 PM   #5 (permalink)
Diesel Freak
 
Join Date: Jun 2011
Location: Lewisville, TX
Posts: 793
Thanks: 134
Thanked 223 Times in 145 Posts
iTrader Score: 0 reviews
It could be an alignment machine that is whacked . . .when I was a kid, my folks had Chevy cars, and in 14+ years, could never align one right (but anyone else could). It was so bad once that a new set of tires has cord showing in about 1000 miles . . .

- Tim
__________________
2011 2WD 2500 Crew Cab ST w/8' bed, bone stock and staying that way . . .
tadawson is offline   Reply With Quote Quick reply to this message
Old 05-23-2013, 12:46 AM   #6 (permalink)
Cummins Nut
 
dgiturbo's Avatar
 
Join Date: May 2013
Location: Woodstock, IL
Posts: 411
Thanks: 62
Thanked 139 Times in 91 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by DPeglow View Post
I bought my truck the begining of May, and i'm taking it back to the dealership friday for the second time....

But now I feel like the tranny is having some issues. Seems like it slips alot before shifting between what I think is 3rd and 4th at about 35MPH and sometimes then slams into 4th gear. Also other times after accelerating to 35-45 MPH and letting off the throttle and then getting back on it theres a 'clunk' from the drivetrain.....

Anyone else having these issues?
Yes, that's exactly what mine is doing. It's at the dealer now so will advise what they say the issue is when I pick it up. There is also another forum member having the same issue also. Same vehicle, RAM 2500 diesel.
__________________
2013 RAM 2500 Laramie CTD, Crew Cab, 4X4 all options. Added: Cabin Air Filter, LineX Bedliner, Craven Speed Stubby Antenna, Nokian Rotiiva 285/70/17
dgiturbo is offline   Reply With Quote Quick reply to this message
Old 05-23-2013, 12:55 AM   #7 (permalink)
Cummins Fan
 
Join Date: May 2013
Posts: 81
Thanks: 2
Thanked 3 Times in 3 Posts
iTrader Score: 0 reviews
mine has a very similar trans issue here is the email I sent to my service manager

Brad
Are there any know software issues with the tranny shift algorithm? My 2013 2500 hd with the cummins with the 68rfe trans clunks and bangs if you get with it to pull out into traffic and then once up to speed let off as the trans shifts to high gear it clunks and bangs or if you are in traffic and on and off the throttle as traffic slows or picks up the pace it acts as if it dont know what gear to be in and clunks and bangs its way to a gear. I ask because I just traded a 5 yr old duramax with 30k on it that shifts perfect and my new truck feels like its got 200k on it and the trans hasnt been serviced since day one. Not unhappy with the truck just hope this isnt normal

Brett
closs2sx is offline   Reply With Quote Quick reply to this message
Old 05-23-2013, 09:10 AM   #8 (permalink)
Cummins Fan
 
Join Date: Apr 2013
Posts: 59
Thanks: 1
Thanked 9 Times in 7 Posts
iTrader Score: 0 reviews
Trans issues

I too was wondering about the shifting. It wasn't as smooth as my 11 1500. As this is my first diesel I chalked it up to being how it was supposed to be. It almost feels like the TC is not locking/unlocking at the correct times. Let me know what you find. On my 1500 there was a TC issue that after 3 trips to the dealership they finally swapped. They never actually found an issue but when I brought them a Star Case number they looked it up and said they could swap it under that case. I'll be bringing it to their attention at the next service window unless someone comes up with a known issue that is documented with a case or recall number.
__________________
Eric
Manassas, VA
2013 Ram 2500 Laramie Rambox crew Shortbed 4x4 black
estoltz is offline   Reply With Quote Quick reply to this message
Old 05-23-2013, 02:27 PM   #9 (permalink)
Cummins Fan
 
Join Date: Dec 2012
Location: Western WA
Posts: 78
Thanks: 53
Thanked 19 Times in 11 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by dgiturbo View Post
Yes, that's exactly what mine is doing. It's at the dealer now so will advise what they say the issue is when I pick it up. There is also another forum member having the same issue also. Same vehicle, RAM 2500 diesel.
My truck (2500 w/ 68RFE) has the same clunking issue, seems to happen if you let off the gas about the same time as it's upshifting to 4th.

I've been driving exclusively in tow/haul mode for the past week, and the tranny doesn't clunk in that mode, so the issue definitely seems to be programming related. Aside from the no clunking, overall driveability of the truck in all speeds/conditions (including empty) seems to be better in tow/haul; shift points are a bit higher keeping the engine from lugging, and the exhaust brake is more effective.

I'd give tow/haul mode a shot until Ram comes up w/ a remedy for the clunking issue. Now I just wish tow/haul would be a "sticky" setting, rather than having to enable it every time the truck is started. Hopefully H&S or another tuner will be able to solve that.

- Chris
__________________
'13 Ram 2500 CCSB Laramie 4x4, 6.7L CTD, 68RFE, factory ordered spring 2013
SnugTop Super Sport and Amp Power Steps for now... 3" Carli lift and 37" tires coming soon...
Slyder is offline   Reply With Quote Quick reply to this message
Old 05-23-2013, 02:57 PM   #10 (permalink)
Cummins Nut
 
dgiturbo's Avatar
 
Join Date: May 2013
Location: Woodstock, IL
Posts: 411
Thanks: 62
Thanked 139 Times in 91 Posts
iTrader Score: 0 reviews
If no resolution from RAM dealer I will try that until an update is released. In the mean time, I found this older TSB info.

"Overview:
This bulletin involves selectively erasing and reprogramming the Transmission Control
Module (TCM) with new software.

Symptom/Condition:
The customer may experience a harsh downshift from the transmission when coming to a
stop. When a vehicle stop is initiated from 4th gear (around 40 Km/h or 25 MPH), the
harsh downshift condition will usually occur as the vehicle decelerates to a speed of about
16 Km/h (10 MPH) . If the transmission is in 2nd, 3rd, 5th, or 6th gear, when the stop is
initiated, the condition will not be present. This may cause the condition to appear to be
intermittent to the customer. Because the harsh downshift may occur below 16 Km/h (10 MPH),
the customer may believe that they are experiencing a harsh 2 - 1 downshift.

Some customers may also experience a harsh 2-3 upshift during normal acceleration.
This symptom is less common than the harsh coastdown shift."
__________________
2013 RAM 2500 Laramie CTD, Crew Cab, 4X4 all options. Added: Cabin Air Filter, LineX Bedliner, Craven Speed Stubby Antenna, Nokian Rotiiva 285/70/17
dgiturbo is offline   Reply With Quote Quick reply to this message
The Following User Says Thank You to dgiturbo For This Useful Post:
Slyder (05-23-2013)
Old 05-23-2013, 03:32 PM   #11 (permalink)
Diesel Freak
 
frobozz's Avatar
 
Join Date: Jan 2013
Location: Mundelein, IL
Posts: 764
Thanks: 8
Thanked 209 Times in 134 Posts
iTrader Score: 0 reviews
I've also been experiencing some less than perfect shifts, but I'm sure that will improve with time... as I learn to master the G56 ;-)

Duncan
__________________
2013 2500 Megacab 6.7L G56 4x4
frobozz is offline   Reply With Quote Quick reply to this message
The Following User Says Thank You to frobozz For This Useful Post:
DIESELBLOCK (05-27-2013)
Old 05-23-2013, 03:54 PM   #12 (permalink)
Cummins Fan
 
Join Date: May 2013
Posts: 81
Thanks: 2
Thanked 3 Times in 3 Posts
iTrader Score: 0 reviews
tow hual smoothed mine right out told ram they need to look at parameters or change my tow haul so it comes on when truck is started as i cant drive it like it is it drives me nuts
closs2sx is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 12:51 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2