Engine code P22B2 ????? - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 4th Generation 2010 and up 6.7 Liter Cummins > 2010-2012 General Discussion
2010-2012 General Discussion General Chit Chat About the 6.7L 4th generation Cummins - NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Reply
 
LinkBack Thread Tools Display Modes
Old 11-14-2013, 10:46 PM   #1 (permalink)
Cummins Fan
 
Join Date: Nov 2010
Posts: 50
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
Engine code P22B2 ?????

Truck has 35k on the clock with zero problems. Switched to Delo full syn last oil change and drove 3,000 mikes round trip to Canada to go hunting. Change engine oil light came on 400 miles into trip. Thought it might be an error. Stopped checked the oil and checked for leaks but found nothing. Reset the light and went on with my trip. Got home and after about a week the light came on again. This time I just changed the oil. Reset the light and after about a day the engine light came on. Hooked up the scanner and all it read was P22B2, see service manual. Service manual has nothing about this. Any idea on what this is? Thanks.
DieselFam is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-15-2013, 03:20 AM   #2 (permalink)
Cummins Fanatic
 
akguy09's Avatar
 
Join Date: Sep 2011
Location: North Pole, Alaska
Posts: 199
Thanks: 14
Thanked 41 Times in 31 Posts
iTrader Score: 0 reviews
has to do with O2 sensors
__________________
'12 CCSB 3500 Longhorn 16.5ti Warn, RaceME,sinister EGR delete,GDP Throttle valve delete,
3"CARLI stuff
akguy09 is offline   Reply With Quote Quick reply to this message
Old 11-15-2013, 01:15 PM   #3 (permalink)
Diesel Freak
 
Join Date: Apr 2011
Location: S. Arkansas
Posts: 764
Thanks: 23
Thanked 81 Times in 59 Posts
iTrader Score: 0 reviews
What truck do you have??


What was the oil level?? Was it climbing up the dipstick??
__________________
2012 ST CCSB 4x4 68RFE Mineral Gray all stock [/QUOTE]
mattmanstroked is offline   Reply With Quote Quick reply to this message
The Following User Says Thank You to mattmanstroked For This Useful Post:
chenry (12-25-2013)
Old 11-16-2013, 12:09 AM   #4 (permalink)
Cummins Fan
 
Join Date: Nov 2010
Posts: 50
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
2012 crew cab long bed 4x4 3500
DieselFam is offline   Reply With Quote Quick reply to this message
Old 12-25-2013, 01:01 AM   #5 (permalink)
Cummins Fan
 
str86's Avatar
 
Join Date: Feb 2012
Location: California
Posts: 54
Thanks: 0
Thanked 2 Times in 1 Post
iTrader Score: 0 reviews
Ever figure it out? I have the same code on my 2011. 3500


Sent from AutoGuide.com App
__________________
99 5speed 4x4,edge ez,k&n CAI,raptor lift pump,stock exhaust no muffler.
2011.5 3500 slt SRW,auto 4x4,all stock
str86 is offline   Reply With Quote Quick reply to this message
Old 12-25-2013, 02:42 AM   #6 (permalink)
Diesel Freak
 
N of 60's Avatar
 
Join Date: Sep 2013
Location: Yukon Canada
Posts: 639
Thanks: 199
Thanked 131 Times in 99 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by str86 View Post
Ever figure it out? I have the same code on my 2011. 3500


Sent from AutoGuide.com App
Emissions still entact. Been there, done that. O2s
__________________
2011 4wd LB/CC 2500 Mineral Gray SLT Auto, H&S Mini,with O/D and MCC by Draconian. Sinister egr delete, 4"TB with factory muffler and tailpipe.Fass platinum 95. Spare Mini in my closet.
N of 60 is offline   Reply With Quote Quick reply to this message
Old 12-26-2013, 09:56 AM   #7 (permalink)
Cummins Fan
 
Join Date: Nov 2010
Posts: 50
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by str86 View Post
Ever figure it out? I have the same code on my 2011. 3500


Sent from AutoGuide.com App
O2 sensors were throwing the code. Apparently I should. Heck with the dealership more often, or take the truck in. Two O2 sensors were either bad or had been recalled and not working. Also there were two wiring harnesses that had been recalled. Dealership had the truck for a day while they replaced everything and rebooted the computer. Truck is stock except for leveling kit and 35's, so it's all good.

The lead tech asked me first if I had any computer upgrades before starting. I don't so there wasn't any issue. I asked him if it would be better if I were to go ahead and do the delete, he smiled and said if I liked my warranty, I should wait.
DieselFam is offline   Reply With Quote Quick reply to this message
Old 12-26-2013, 10:48 AM   #8 (permalink)
Saz
Cummins Enthusiast
 
Saz's Avatar
 
Join Date: Feb 2013
Location: Windsor, CO
Posts: 255
Thanks: 57
Thanked 64 Times in 51 Posts
iTrader Score: 0 reviews
Take it to the dealer. I had the same code, and after 4 trips to the dealer it got deleted. They just kept replacing parts in the hope that eventually it would fix the problem. One of the diesel techs told me that 90% of these trucks that come in for warranty work are emissions related. Check with your servicing dealer first and see exactly what will and will not be covered after you delete if that is an option.
__________________
2011 3500 CCLB, DRW, 4X4, 3.73, Flo-Pro 4" downpipe+delete pipe, Mini Maxx MCC by Draconian Diesel, 255/80R17 Cooper ST Maxx
Saz is offline   Reply With Quote Quick reply to this message
The Following User Says Thank You to Saz For This Useful Post:
JaredMagun (12-26-2013)
Old 12-26-2013, 10:01 PM   #9 (permalink)
Diesel Freak
 
JaredMagun's Avatar
 
Join Date: Sep 2012
Location: SC
Posts: 503
Thanks: 15
Thanked 20 Times in 20 Posts
iTrader Score: 0 reviews
saz you had exactly the same experience I had...
__________________
FAMILY FIRST
2010 Ram 2500 Laramie 4x4 CCSB, 6.7, 3.73, Husky Mudflaps, Weathertech Digital fit mats, Leer Campertop, 285/70/17 BFG AT\KO
JaredMagun is offline   Reply With Quote Quick reply to this message
Old 12-26-2013, 10:11 PM   #10 (permalink)
Diesel Freak
 
N of 60's Avatar
 
Join Date: Sep 2013
Location: Yukon Canada
Posts: 639
Thanks: 199
Thanked 131 Times in 99 Posts
iTrader Score: 0 reviews
same road traveled.
__________________
2011 4wd LB/CC 2500 Mineral Gray SLT Auto, H&S Mini,with O/D and MCC by Draconian. Sinister egr delete, 4"TB with factory muffler and tailpipe.Fass platinum 95. Spare Mini in my closet.
N of 60 is offline   Reply With Quote Quick reply to this message
Old 12-27-2013, 10:39 AM   #11 (permalink)
Saz
Cummins Enthusiast
 
Saz's Avatar
 
Join Date: Feb 2013
Location: Windsor, CO
Posts: 255
Thanks: 57
Thanked 64 Times in 51 Posts
iTrader Score: 0 reviews
Yeah, I even deleted with SIMS first and kept getting the same 02 sensor code. The senior Diesel Tech pulled me off to the side and said, "go get a tuner and shut all that crap off and make it run like it is supposed to." I did and have not looked back since.
__________________
2011 3500 CCLB, DRW, 4X4, 3.73, Flo-Pro 4" downpipe+delete pipe, Mini Maxx MCC by Draconian Diesel, 255/80R17 Cooper ST Maxx
Saz is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 12:32 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2