Service required See dealer now!?! - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 07.5 - 09 6.7 Liter Cummins > 07.5 - 09 3rd Gen 6.7L Performance Parts Discussion
07.5 - 09 3rd Gen 6.7L Performance Parts Discussion Discussion of Performance Parts For the 6.7L Trucks...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Reply
 
LinkBack Thread Tools Display Modes
Old 12-27-2010, 02:28 PM   #1 (permalink)
Cummins Fanatic
 
Bmega2500's Avatar
 
Join Date: Nov 2008
Location: Virginia
Posts: 154
Thanks: 3
Thanked 7 Times in 7 Posts
iTrader Score: 0 reviews
Service required See dealer now!?!

I got a "service required see dealer now" ding in the overhead display. Took it in and the dealer said there were no codes and nothing wrong. I have the rolling smoke diesel egr delete, H&S XRT and a 4" TBE. Runs fine but the damn overhead dings at me every 15 mins or so. Anyone have any ideas? Dealer guessed that i need to download the updated software from H&S? XRT is only about 8 months old. HELP!
__________________
Present vehicle:
2012 Ram 3500 CCLB Laramie, 4" TB MBRP, H&S XRT Pro, Fully deleted, 20x9 BMF Novakanes, 35x12.50 Toyo M/T's
Bmega2500 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-27-2010, 02:31 PM   #2 (permalink)
Diesel Freak
 
2rowdy's Avatar
 
Join Date: Feb 2008
Location: Wilson, Tx
Posts: 809
Thanks: 56
Thanked 52 Times in 25 Posts
iTrader Score: 0 reviews
It would probably help to go ahead and clear the codes. I know thare is none showing, happens occasionally with SMARTY and that fixes it. Sometimes I do it twice just for good measure.
__________________
THE GREAT WRECKING YARD IN TH SKY
2007.5, 6.7, ISSPRO rail pressure, boost, trans temp. Edge j/a,w/hot unplugged. extreme power puck ,SMARTY. ATS tranny. HTT 66/73/13-SS, DTT grid heater delete, ATS Co-Pilot

I have decided against going green

98 12v, 5 speed, ECLB, 4x4. Stock for now.
2rowdy is offline   Reply With Quote Quick reply to this message
The Following User Says Thank You to 2rowdy For This Useful Post:
itsabeast (12-29-2010)
Old 12-27-2010, 03:24 PM   #3 (permalink)
Cummins Fanatic
 
Join Date: May 2009
Posts: 194
Thanks: 7
Thanked 8 Times in 8 Posts
iTrader Score: 0 reviews
there have been many posts on this issue. how many miles are on your truck? I would try updating your XRT, both times I have had that show up in my ohd i updated my black maxx and it has fixed the problem.
__________________
2008 2500 6.7, AFE Mega Cannon, Black Maxx, BOD intake horn, RSD 5" tbe, Shibby boost tube, shibby cooler delete, southbend 3600 dual disk with upgraded hydraulics.
black08cummins is offline   Reply With Quote Quick reply to this message
Old 12-27-2010, 03:39 PM   #4 (permalink)
H&S Performance
 
H&S TECH's Avatar
 
Join Date: Mar 2009
Posts: 1,260
Thanks: 109
Thanked 799 Times in 327 Posts
iTrader Score: 1 reviews
Most commonly that message is due to the Crank Case vent filter needing to be replaced. Reset the message and see if it comes back:

Factory Vehicle Tech - H&S Performance
__________________
H&S TECH is offline   Reply With Quote Quick reply to this message
Old 12-28-2010, 04:57 PM   #5 (permalink)
Cummins Fanatic
 
Bmega2500's Avatar
 
Join Date: Nov 2008
Location: Virginia
Posts: 154
Thanks: 3
Thanked 7 Times in 7 Posts
iTrader Score: 0 reviews
H&S,

I just did the crankcase filter and reset the message.. that was "PERFORM SERVICE" This is "SERVICE REQUIRED" "SEE DEALER NOW" I will try to reset it again though.
__________________
Present vehicle:
2012 Ram 3500 CCLB Laramie, 4" TB MBRP, H&S XRT Pro, Fully deleted, 20x9 BMF Novakanes, 35x12.50 Toyo M/T's
Bmega2500 is offline   Reply With Quote Quick reply to this message
Old 12-28-2010, 05:11 PM   #6 (permalink)
Cummins Nut
 
Join Date: Dec 2009
Location: Milton, NH
Posts: 342
Thanks: 8
Thanked 11 Times in 11 Posts
iTrader Score: 1 reviews
It happens to my truck every 2000 miles or so...somewhere in there, havent paid attention enough to figure out exactly when it happens, but it seems to be consistent. I just reload my tune with the Smarty and it goes away for another ~2000 miles

I read somewhere something about it automatically happening because the truck isnt going into regen (no DPF = no regen) and its an automatic response because the truck thinks something might be wrong, since its gone so long without a regen

Little does the big guy know, that stupid turd of a DPF is in the basement rotting away...
__________________
Khaki '08 3500 SRW Quad Cab SLT 4x4, Auto, 6.7L, 35x12.50 BFG M/Ts on 17" American Racing wheels, Access Tonneau, LINEX'ed bed, 5" TBE, H&S EGR/cooler delete, Smarty Jr
Blstr88 is offline   Reply With Quote Quick reply to this message
Old 12-28-2010, 11:36 PM   #7 (permalink)
Newbie
 
08 6.7's Avatar
 
Join Date: Dec 2008
Location: Roanoke Va
Posts: 13
Thanks: 2
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
When that light came on my truck i replaced the CCV filter and Reset the timers on the XRT. Try that and reset the light with the Brake-brake-gas-gas trick.
__________________
08 6.7L G56 Quad Cab--H&S 5" TBE - EGR/Cooler Delete - MiniMaxx - AFE Mega Cannon II - Black Ops Intake Horn - Shibby Boost Tube - 305/65/17 Nitto Terra Grapplers
08 6.7 is offline   Reply With Quote Quick reply to this message
Old 12-29-2010, 03:33 AM   #8 (permalink)
Diesel Head
 
Spody's Avatar
 
Join Date: Oct 2010
Location: Central Alberta
Posts: 1,096
Thanks: 133
Thanked 146 Times in 125 Posts
iTrader Score: 0 reviews
Did the dealer just use the key trick to see if it had codes or did they use the starscan ?
Either way, I can't believe they wouldn't reset it for you
On the plus side, they didn't seem to care that you had deletes and the XRT
__________________
'08 3500 Mega SRW, Laramie, Auto, 6" lift, 37" Toyo OC MT's on 20" Moto Metal 961's . Minimaxx, Deleted, B&G tuned TCM
[SIGPIC][/SIGPIC]
'12 3500 CC LB DRW Laramie, Max tow. It's the wife's
Spody is offline   Reply With Quote Quick reply to this message
Old 12-29-2010, 08:03 AM   #9 (permalink)
Cummins Fanatic
 
Bmega2500's Avatar
 
Join Date: Nov 2008
Location: Virginia
Posts: 154
Thanks: 3
Thanked 7 Times in 7 Posts
iTrader Score: 0 reviews
Im not sure if they used a starscan or not?.......Yeah the dealer is really cool about the deletes and they help me out whenever they can. The diesel tech is very good and knowledgeable.
__________________
Present vehicle:
2012 Ram 3500 CCLB Laramie, 4" TB MBRP, H&S XRT Pro, Fully deleted, 20x9 BMF Novakanes, 35x12.50 Toyo M/T's
Bmega2500 is offline   Reply With Quote Quick reply to this message
Old 01-04-2011, 08:29 AM   #10 (permalink)
Cummins Enthusiast
 
Bored_And_Stroked's Avatar
 
Join Date: Sep 2009
Location: Tidewater, Virginia
Posts: 217
Thanks: 37
Thanked 65 Times in 38 Posts
iTrader Score: 0 reviews
Got the Service Required See Dealer Now message yesterday for the 1st time. I have an 08 with just 29K on the clock with full deletes and H&S Black Maxx.

The truck has been deleted since new in 08 and has had a XRT at first and now a BM since then. Never have I got this message before. So I doubt it took my truck 28,000 miles to finally learn that the DPF fell off.

This is message is something different from "Perform Service" which deals with the CCV.
__________________
08 Inferno Red Dodge with Stuff

Last edited by Bored_And_Stroked; 01-04-2011 at 09:10 AM. Reason: Clarification
Bored_And_Stroked is offline   Reply With Quote Quick reply to this message
Old 01-04-2011, 09:07 AM   #11 (permalink)
Cummins Enthusiast
 
Bored_And_Stroked's Avatar
 
Join Date: Sep 2009
Location: Tidewater, Virginia
Posts: 217
Thanks: 37
Thanked 65 Times in 38 Posts
iTrader Score: 0 reviews
I found this regarding resetting the "Service Required See Dealer Now"

My H&S Black Maxx will not turn off this warning by clearing DTCs.

This is what I found out about resetting the ECM:

1. Unhook both of your negative cables. Make sure when you lay them down, that they're not touching anything metal.

2. Unhook both of your positive cables. Lay them down so they don't touch anything metal.

(note: this is a good time to clean them up if they need it)

3. When you have all 4 unhooked, touch one pair of cables together (ie. driver's side pos. and neg.), then lay them back down...again making sure they don't touch metal. Do the same for the other side.

4. Reconnect your positive cables and tighten them.

5. Reconnect the negative cables and tighten them.

This process will reset the ECM. Learned that from a friend who is a dealer tech.

thread link OHC Service Required Reset - 6.7 Cummins Forum

Also regarding this just recently appearing, I think it has something to do with me disconnecting my negative cables to clean them over the weekend. I think that may have triggered this warning. It happened the first time I drove the truck after doing so.
__________________
08 Inferno Red Dodge with Stuff
Bored_And_Stroked is offline   Reply With Quote Quick reply to this message
Old 01-05-2011, 06:06 PM   #12 (permalink)
Cummins Fanatic
 
Bmega2500's Avatar
 
Join Date: Nov 2008
Location: Virginia
Posts: 154
Thanks: 3
Thanked 7 Times in 7 Posts
iTrader Score: 0 reviews
Will resetting the ecm effect the XRT? Will i need to reload my tune?
__________________
Present vehicle:
2012 Ram 3500 CCLB Laramie, 4" TB MBRP, H&S XRT Pro, Fully deleted, 20x9 BMF Novakanes, 35x12.50 Toyo M/T's
Bmega2500 is offline   Reply With Quote Quick reply to this message
The Following User Says Thank You to Bmega2500 For This Useful Post:
Leo43 (08-20-2012)
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 09:25 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2